FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » sql error when writing listserv integration rule
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
sql error when writing listserv integration rule [message #30221] Sat, 11 February 2006 20:43 Go to next message
Dave Stevens is currently offline  Dave Stevens   United States
Messages: 2
Registered: November 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I'm integrating a mailing list into a forum and when I attempt to write the rule in the admin panel, the following is returned and the process dies, not adding the rule.

Quote:

(/var/www/forumdata/include/theme/default/db.inc:73
/var/www/forumdata/include/theme/default/db.inc:177
/var/www/forumdata/include/mlist.inc:76
/var/www/forum/adm/admmlist.php:41
) 1136: Column count doesn't match value count at row 1
Query: INSERT INTO fud26_mlist( forum_id, name, mlist_opt, subject_regex_haystack, subject_regex_needle, body_regex_haystack, body_regex_needle, additional_headers ) VALUES( 3, 'THEATRE-SOUND(at)LISTSERV(dot)AOL(dot)COM', 72, '', '', '', '', '', '' )
_POST: array ( 'S' => '0d3643c9d03fbd32a5712ef8562a8a69', 'SQ' => 'e827135f4f615111c195b50bd20ab7ca', 'ml_name' => 'THEATRE-SOUND(at)LISTSERV(dot)AOL(dot)COM', 'ml_forum_id' => '3', 'ml_mlist_post_apr' => '0', 'ml_allow_frm_post' => '0', 'ml_frm_post_apr' => '0', 'ml_allow_mlist_attch' => '8', 'ml_allow_mlist_html' => '0', 'ml_complex_reply_match' => '0', 'ml_create_users' => '64', 'ml_skip_non_forum_users' => '0', 'ml_subject_regex_haystack' => '', 'ml_subject_regex_haystack_opt' => '', 'ml_subject_regex_needle' => '', 'ml_body_regex_haystack' => '', 'ml_body_regex_haystack_opt' => '', 'ml_body_regex_needle' => '', 'ml_additional_headers' => '', 'ml_custom_sig' => '', 'ml_submit' => 'Add Mailing List Rule', 'edit' => '', )
Server Version: 3.23.58
[Referring Page] http://forum.roaddog.com/adm/admmlist.php?S=0d3643c9d03fbd32a5712ef8562a8a6 9&SQ=e827135f4f615111c195b50bd20ab7ca


I dumped the database, dropped it and restored it and still the same error. Forum files unlocked in the admin panel prior to running the script.

TIA
Dave
Re: sql error when writing listserv integration rule [message #30236 is a reply to message #30221] Sun, 12 February 2006 14:07 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Fixed in CVS, here is the patch:
http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=7545


FUDforum Core Developer
Re: sql error when writing listserv integration rule [message #30243 is a reply to message #30236] Sun, 12 February 2006 16:04 Go to previous messageGo to next message
Dave Stevens is currently offline  Dave Stevens   United States
Messages: 2
Registered: November 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks. Resolved.

Dave
Re: sql error when writing listserv integration rule [message #30321 is a reply to message #30243] Fri, 17 February 2006 14:27 Go to previous messageGo to next message
mischa is currently offline  mischa   Netherlands
Messages: 7
Registered: February 2006
Location: NL
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have exactly the same problem in version 2-7-4
But how do i install the cvs fix??!!

Thanks
Re: sql error when writing listserv integration rule [message #30322 is a reply to message #30321] Fri, 17 February 2006 14:56 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You apple the patch listed in the url above and rebuild the theme.

FUDforum Core Developer
Re: sql error when writing listserv integration rule [message #30326 is a reply to message #30322] Fri, 17 February 2006 16:10 Go to previous message
mischa is currently offline  mischa   Netherlands
Messages: 7
Registered: February 2006
Location: NL
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I pressed my apple key and it's fixed Razz
Not really but I downloaded the mlist.inc(.txt) replaced it in the includes folder (after backingup the old one) and patched it! It works, thx Ilia!
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: rose cant validate
Next Topic: Mailing list integration problem
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Sep 19 18:40:08 EDT 2018

Total time taken to generate the page: 0.00605 seconds