FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » using xampp on windows PHP5 install fails
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
using xampp on windows PHP5 install fails [message #30994] Fri, 24 March 2006 05:02 Go to next message
madhead is currently offline  madhead   United Kingdom
Messages: 7
Registered: March 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi I have just attempted to install fudforum on xampp with php5 enabled and the install.php fails with an error in apache. If I switch to PHP4 the install goes fine. any ideas why it has a problem with PHP5 ?

Also can you use this forum with flat files? I have a mate that wants a forum but doesn't have a hosting with database available to him only php.Any suggestions would be great (even a cheaper isp with db support i.e <= 7.95/pm)

Madhead.

[Updated on: Fri, 24 March 2006 05:04]

Report message to a moderator

Re: using xampp on windows PHP5 install fails [message #31002 is a reply to message #30994] Fri, 24 March 2006 11:17 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
What version of PHP (specifically)? FUDforum supports SQLite database, which is pretty much a flag file.

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #31005 is a reply to message #31002] Fri, 24 March 2006 11:18 Go to previous messageGo to next message
madhead is currently offline  madhead   United Kingdom
Messages: 7
Registered: March 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
http://www.apachefriends.org/en/xampp-windows.html

Gives full details
PHP 5.1.1

[Updated on: Fri, 24 March 2006 11:24]

Report message to a moderator

Re: using xampp on windows PHP5 install fails [message #31009 is a reply to message #31005] Fri, 24 March 2006 11:30 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
What is the error that are you seeing?

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #31016 is a reply to message #31009] Fri, 24 March 2006 12:01 Go to previous messageGo to next message
madhead is currently offline  madhead   United Kingdom
Messages: 7
Registered: March 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
PATH OF SYSTEM FILES AND DIRECTORIES Step 1 of 5

it crashes apache when ou click next on this page
Re: using xampp on windows PHP5 install fails [message #31031 is a reply to message #31016] Sun, 26 March 2006 12:49 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Sounds like a bug in your version of PHP.

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #31033 is a reply to message #31031] Sun, 26 March 2006 17:44 Go to previous messageGo to next message
madhead is currently offline  madhead   United Kingdom
Messages: 7
Registered: March 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ok I'll just use PHP 4 for now then that seems to work ok.
But I would still like to use this BB without Database is that possible? Could u tell me a little more about SQLLite at all?

Thanks,
Madhead
Re: using xampp on windows PHP5 install fails [message #31039 is a reply to message #31033] Mon, 27 March 2006 18:26 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
SQLite is a flat file database system that comes by default with PHP 5 and higher. You can find more info about it at http://www.sqlite.org

FUDforum Core Developer
icon10.gif  Re: using xampp on windows PHP5 install fails [message #31045 is a reply to message #31039] Tue, 28 March 2006 08:58 Go to previous messageGo to next message
madhead is currently offline  madhead   United Kingdom
Messages: 7
Registered: March 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ok thanks. I have had a look as suggested. So basically in order to use FUDForum with sqlite I need a host with PHP5 is that right?

If so I can switch from the present w2k3 solution running PHP4 to linux and PHP5.

Cheers,
Razz

[Updated on: Tue, 28 March 2006 09:04]

Report message to a moderator

Re: using xampp on windows PHP5 install fails [message #31047 is a reply to message #31045] Tue, 28 March 2006 09:13 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
That is correct.

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #31253 is a reply to message #31016] Wed, 12 April 2006 09:40 Go to previous messageGo to next message
ggray is currently offline  ggray   Ukraine
Messages: 96
Registered: October 2004
Location: Crimea: Simferopol
Karma: 0
Member
add to buddy list
ignore all messages by this user

madhead wrote on Fri, 24 March 2006 19:01

PATH OF SYSTEM FILES AND DIRECTORIES Step 1 of 5

it crashes apache when ou click next on this page


hmm... I'm replicate the problem Confused
configuration: WinXPSP2, Apache 2.0.55, PHP 5.1.2

[Updated on: Wed, 12 April 2006 09:40]

Report message to a moderator

Re: using xampp on windows PHP5 install fails [message #31265 is a reply to message #31253] Thu, 13 April 2006 12:16 Go to previous messageGo to next message
ggray is currently offline  ggray   Ukraine
Messages: 96
Registered: October 2004
Location: Crimea: Simferopol
Karma: 0
Member
add to buddy list
ignore all messages by this user

any thoughts how to debug whitch module is responsible for this?
Re: using xampp on windows PHP5 install fails [message #31277 is a reply to message #31265] Fri, 14 April 2006 16:26 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
There is a bug in PHP on win32 that causes a crash a workaround for it was added to CVS. You can get it from here and patch your install.php with it

http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=7570


FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #31308 is a reply to message #31277] Sat, 15 April 2006 20:09 Go to previous messageGo to next message
madhead is currently offline  madhead   United Kingdom
Messages: 7
Registered: March 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks, I will have a go at that but I have now ended up using yabb2.1. (still that is perl so maybe I will switch anyway Smile

I have attempted to install fudforum with the latest install.php script complete with patch as described. My isp hosting company is using PHP5.0.3RC1 with sqlite enabled. However when I run the install script it outputs the following :-

FUDforum can utilize either MySQL PosgreSQL or SQLite database to store it's data, unfortunately, your PHP does not have support for either one. Please install or load the appropriate database extension and then re-run the install script.
I find this odd as I can run sqlitemanager without problems. Can u point me to a solution or at least a means of debugging what the problem is? I can post my phpinfo() if needed.

Thanks







[Updated on: Sat, 15 April 2006 20:51]

Report message to a moderator

Re: using xampp on windows PHP5 install fails [message #31310 is a reply to message #31308] Sun, 16 April 2006 14:15 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The forum uses php's extension_loaded() function to determine what database drivers are loaded. So, it would seem on your install this function does not report correctly the status of the extensions that you have.

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #31317 is a reply to message #30994] Sun, 16 April 2006 23:56 Go to previous messageGo to next message
sdash is currently offline  sdash   United States
Messages: 3
Registered: April 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi,

Could you please tell me the instructions to patch the install script?

Satya
Re: using xampp on windows PHP5 install fails [message #31318 is a reply to message #30994] Mon, 17 April 2006 00:11 Go to previous messageGo to next message
sdash is currently offline  sdash   United States
Messages: 3
Registered: April 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I am getting this error when i tried to patch and then ran the install.script.

Archive did not pass checksum test, CORRUPT ARCHIVE!
If you've encountered this error it means that you've:
downloaded a corrupt archive
uploaded the archive in ASCII and not BINARY mode
your FTP Server/Decompression software/Operating System added un-needed cartrige return (' ') characters to the archive, resulting in archive corruption.
Re: using xampp on windows PHP5 install fails [message #31323 is a reply to message #31318] Mon, 17 April 2006 18:30 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to use the patch utility, patch -p0 < patch_file_name

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #31368 is a reply to message #31323] Wed, 19 April 2006 04:49 Go to previous messageGo to next message
ggray is currently offline  ggray   Ukraine
Messages: 96
Registered: October 2004
Location: Crimea: Simferopol
Karma: 0
Member
add to buddy list
ignore all messages by this user

Ilia wrote on Tue, 18 April 2006 01:30

You need to use the patch utility, patch -p0 < patch_file_name


should we patch CVS install.php file, or full distributive install.php?, because when I patch install.php for 2.7.4 (with patch utility) I got the same message:
Quote:

Archive did not pass checksum test, CORRUPT ARCHIVE!
If you've encountered this error it means that you've:
downloaded a corrupt archive
uploaded the archive in ASCII and not BINARY mode
your FTP Server/Decompression software/Operating System added un-needed cartrige return (' ') characters to the archive, resulting in archive corruption.

[Updated on: Wed, 19 April 2006 04:49]

Report message to a moderator

Re: using xampp on windows PHP5 install fails [message #31381 is a reply to message #31368] Wed, 19 April 2006 16:40 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to patch the distributed install.php. Get a fresh copy of the file and the patch it, the patch only affects the installer's PHP code and should have no impact on the archive.

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #31386 is a reply to message #30994] Thu, 20 April 2006 01:57 Go to previous messageGo to next message
sdash is currently offline  sdash   United States
Messages: 3
Registered: April 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Unfortunately, it still throws the same archive error. Is there any other work around? When is the next release is expected to come out?

Satya
Re: using xampp on windows PHP5 install fails [message #31391 is a reply to message #31386] Thu, 20 April 2006 09:24 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
NExt release should be in early May.

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #31524 is a reply to message #30994] Wed, 03 May 2006 11:10 Go to previous messageGo to next message
ggray is currently offline  ggray   Ukraine
Messages: 96
Registered: October 2004
Location: Crimea: Simferopol
Karma: 0
Member
add to buddy list
ignore all messages by this user

BUG repeated with PHP5.1.3 Evil or Very Mad and standard 2.7.4 FUDforum installation
waiting 2.7.5 version of FUDforum, because early may Very Happy

[Updated on: Wed, 03 May 2006 11:11]

Report message to a moderator

Re: using xampp on windows PHP5 install fails [message #31619 is a reply to message #31391] Wed, 10 May 2006 08:52 Go to previous messageGo to next message
ggray is currently offline  ggray   Ukraine
Messages: 96
Registered: October 2004
Location: Crimea: Simferopol
Karma: 0
Member
add to buddy list
ignore all messages by this user

Windows XPSP2, php 5.1.4
no FTP Server/client was used.
problem:
Quote:


Archive did not pass checksum test, CORRUPT ARCHIVE!
If you've encountered this error it means that you've:
downloaded a corrupt archive
uploaded the archive in ASCII and not BINARY mode
your FTP Server/Decompression software/Operating System added un-needed cartrige return (' ') characters to the archive, resulting in archive corruption.

Re: using xampp on windows PHP5 install fails [message #31625 is a reply to message #31619] Wed, 10 May 2006 09:01 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Did you download the zip file or the tar.gz or tar.bz2 files? Can you try downloading the tar.gz and/or tag.bz2 files and running them. Also, when you decompress those files compare install.php found within to the one you have to see if the two are the same.

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #31692 is a reply to message #31625] Fri, 12 May 2006 08:43 Go to previous messageGo to next message
ggray is currently offline  ggray   Ukraine
Messages: 96
Registered: October 2004
Location: Crimea: Simferopol
Karma: 0
Member
add to buddy list
ignore all messages by this user

downloaded all:

FUDforum_zl_2-7-5RC1.tar.gz
FUDforum_zl_2-7-5RC1.tar.bz2
FUDforum_zl_2-7-5RC1.zip

FUDforum_2-7-5RC1.tar.gz
FUDforum_2-7-5RC1.tar.bz2
FUDforum_2-7-5RC1.zip

they are identical for each other.
but I have the same problem ('Archive did not pass checksum test').

PS
I repeat, I don't use any FTP program, just download, extract and try to install on local machine
Re: using xampp on windows PHP5 install fails [message #31742 is a reply to message #31692] Mon, 15 May 2006 22:25 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Fixed in CVS, I'll release 2.7.5RC2 with the fix in it.

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #31756 is a reply to message #31742] Tue, 16 May 2006 12:36 Go to previous messageGo to next message
ggray is currently offline  ggray   Ukraine
Messages: 96
Registered: October 2004
Location: Crimea: Simferopol
Karma: 0
Member
add to buddy list
ignore all messages by this user

Great works now Twisted Evil
Re: using xampp on windows PHP5 install fails [message #32966 is a reply to message #31016] Mon, 07 August 2006 08:32 Go to previous messageGo to next message
JanRei is currently offline  JanRei   Germany
Messages: 361
Registered: October 2005
Location: Germany
Karma: 0
Senior Member
Contributing Core Developer
Translator
add to buddy list
ignore all messages by this user
madhead wrote on Fri, 24 March 2006 18:01

PATH OF SYSTEM FILES AND DIRECTORIES Step 1 of 5

it crashes apache when ou click next on this page

I have the same problem. Sad

PHP: 5.1.4
FUDforum: latest CVS
Re: using xampp on windows PHP5 install fails [message #32975 is a reply to message #32966] Mon, 07 August 2006 13:51 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Latest CVS of FUDforum? You built your own install.php using online instructions?
Does your PHP actually crash or some other error occurs?


FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #32991 is a reply to message #30994] Tue, 08 August 2006 04:05 Go to previous messageGo to next message
JanRei is currently offline  JanRei   Germany
Messages: 361
Registered: October 2005
Location: Germany
Karma: 0
Senior Member
Contributing Core Developer
Translator
add to buddy list
ignore all messages by this user
Yes, I build my own install.php from CVS using the instructions.
I click on "Next" in the first installation step and Apache crashes after a few seconds. According to Windows the culprit is php5ts.dll.
Re: using xampp on windows PHP5 install fails [message #33001 is a reply to message #32991] Tue, 08 August 2006 11:54 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I've just tried FUDforum 2.7.5 (zipped non-zlib archive) on PHP 5.1.4 running as Apache module on Apache 1.3 on Win32 and it was able to pass the first step of the installer without crashing.

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #33003 is a reply to message #30994] Tue, 08 August 2006 15:39 Go to previous messageGo to next message
JanRei is currently offline  JanRei   Germany
Messages: 361
Registered: October 2005
Location: Germany
Karma: 0
Senior Member
Contributing Core Developer
Translator
add to buddy list
ignore all messages by this user
I am using Apache 2.2.2 could this be the problem?

Here are the server details:
Apache/2.2.2 (Win32) DAV/2 mod_ssl/2.2.2 OpenSSL/0.9.8b mod_autoindex_color PHP/5.1.4
Re: using xampp on windows PHP5 install fails [message #33004 is a reply to message #33003] Tue, 08 August 2006 15:43 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Could be, do other PHP scripts run fine?

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #33006 is a reply to message #30994] Tue, 08 August 2006 16:10 Go to previous messageGo to next message
JanRei is currently offline  JanRei   Germany
Messages: 361
Registered: October 2005
Location: Germany
Karma: 0
Senior Member
Contributing Core Developer
Translator
add to buddy list
ignore all messages by this user
Yes, no problems with running phpBB2 or phpMyAdmin.

[Updated on: Tue, 08 August 2006 16:16]

Report message to a moderator

Re: using xampp on windows PHP5 install fails [message #33009 is a reply to message #33006] Tue, 08 August 2006 16:34 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you tried running the 2.7.5 installer? Can you send me your installer?

FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #33037 is a reply to message #30994] Wed, 09 August 2006 07:56 Go to previous messageGo to next message
JanRei is currently offline  JanRei   Germany
Messages: 361
Registered: October 2005
Location: Germany
Karma: 0
Senior Member
Contributing Core Developer
Translator
add to buddy list
ignore all messages by this user
I think I got it, could you try installer with zlib?
I also have no problems running non-zlib installer.
Re: using xampp on windows PHP5 install fails [message #33064 is a reply to message #30994] Thu, 10 August 2006 10:41 Go to previous messageGo to next message
JanRei is currently offline  JanRei   Germany
Messages: 361
Registered: October 2005
Location: Germany
Karma: 0
Senior Member
Contributing Core Developer
Translator
add to buddy list
ignore all messages by this user
In case you can't reproduce it, I sent my installer to ilia at prohost dot org.
And yes, the installer of 2.7.5 is crashing too.
Re: using xampp on windows PHP5 install fails [message #33073 is a reply to message #33064] Thu, 10 August 2006 16:53 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Fixed, although the real bug lies in PHP win32 builds, however I did come with a work-around. You can find the relevant patch here.
http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=11546


FUDforum Core Developer
Re: using xampp on windows PHP5 install fails [message #33076 is a reply to message #30994] Fri, 11 August 2006 05:36 Go to previous messageGo to previous message
JanRei is currently offline  JanRei   Germany
Messages: 361
Registered: October 2005
Location: Germany
Karma: 0
Senior Member
Contributing Core Developer
Translator
add to buddy list
ignore all messages by this user
Thank you.
Shall I make a bug report?
Quick Reply
Formatting Tools:   
Pages (2): [1  2    »]  Switch to threaded view of this topic Create a new topic
Previous Topic: .htaccess file automatically being create
Next Topic: install problem of WWW_ROOT
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 20 23:56:25 EDT 2018

Total time taken to generate the page: 0.01251 seconds