Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Tomcat/PHP null IOException Solved
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
icon7.gif  Tomcat/PHP null IOException Solved [message #31084] Thu, 30 March 2006 16:50 Go to next message
gsl1 is currently offline  gsl1   United States
Messages: 1
Registered: February 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I am posting this in the hopes that it may help someone else who accidentally wanders down this path. Based upon a search of the net, others have in the past but no solution was presented. I ran into the following problem while attempting to get the PHP java servlet running inside Tomcat 5.5.15 prior to installing FUDforum:

java.io.IOException: null
net.php.servlet.send(Native Method)

This exception occurred while attempting to go to URL:


where test.php contained:

<?php phpinfo(); ?>

Without going into all the gory details, the bottom line is that I mistakenly placed the test.php file directly under Tomcat's webapps directory instead of the webapps/ROOT directory. This causesd a file not found IO error when the C code attempted an fopen which bubbled up as the exception shown above. Anyone who is interested in the details can look in the Tomcat users newsgroup archive under subject "PHP Servlet Fails in Tomcat 5.5.15".

I was using:

Suse Linux 9.3
gsl@aragorn:~/tomcat/apache-tomcat-5.5.15/logs> uname -a
Linux aragorn #1 Tue Nov 29 14:32:49 UTC 2005
i686 i686 i386 GNU/Linux

gsl@aragorn:~/tomcat/apache-tomcat-5.5.15/logs> java -version
java version "1.5.0_04"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_04-b05)
Java HotSpot(TM) Client VM (build 1.5.0_04-b05, mixed mode, sharing)

Tomcat 5.5.15 installed under my home directory to avoid any
permissions problems.

gsl@aragorn:~> php -i | less
PHP Version => 4.3.10

System => Linux aragorn #1 Tue Nov 29 14:32:49 UTC 2005 i686
Build Date => Apr 23 2005 03:44:40
Configure Command => './configure' '--prefix=/usr' '--datadir=/usr/share/php' '--mandir=/usr/share/man' '--bin
dir=/usr/bin' '--libdir=/usr/share' '--includedir=/usr/include' '--sysconfdir=/etc' '--with-_lib=lib' '--with-c
onfig-file-path=/etc' '--with-exec-dir=/usr/lib/php/bin' '--disable-debug' '--enable-inline-optimization' '--en
able-memory-limit' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sigchild' '--disable-ctype' '--disabl
e-session' '--without-mysql' '--disable-cli' '--without-pear' '--with-openssl' '--enable-force-cgi-redirect' '-
-enable-discard-path' '--enable-cli' '--with-pear' 'i586-suse-linux'
Server API => Command Line Interface
Virtual Directory Support => disabled
Configuration File (php.ini) Path => /etc/php.ini
PHP API => 20020918
PHP Extension => 20020429
Zend Extension => 20021010
Debug Build => no
Thread Safety => disabled
Registered PHP Streams => php, http, ftp, https, ftps, compress.zlib

This program makes use of the Zend Scripting Language Engine:
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

-=> Gregg <=-
Re: Tomcat/PHP null IOException Solved [message #31094 is a reply to message #31084] Sat, 01 April 2006 12:58 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Core Developer
add to buddy list
ignore all messages by this user
Thanks for the detailed analysis, I am sure it'd be most helpful to FUDforum users on Tomcat.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Next Topic: Internet Explorer link bug (maybe) in search results.
Goto Forum:

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Dec 14 23:39:08 EST 2018

Total time taken to generate the page: 0.00660 seconds