FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » FUDforum 3.0+ » can't create/edit polls
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
icon7.gif  can't create/edit polls [message #3683] Thu, 04 July 2002 08:55 Go to next message
ctbk is currently offline  ctbk   Italy
Messages: 142
Registered: April 2002
Location: Milan, Italy
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I'm using Fud 2.0.2 and when I try to create a thread with a poll the "poll editor" pops up, but it won't save my changes... I can create/delete options and all, but if I push the last button on the bottom right of the screen (Update) nothing happens.

Thanx, later.
Ste


~
~
:wq
Re: can't create/edit polls [message #3685 is a reply to message #3683] Thu, 04 July 2002 09:18 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
ctbk wrote on Thu, 04 July 2002 08:55

I'm using Fud 2.0.2 and when I try to create a thread with a poll the "poll editor" pops up, but it won't save my changes... I can create/delete options and all, but if I push the last button on the bottom right of the screen (Update) nothing happens.

Thanx, later.
Ste


When you push the button do you get any JavaScript errors?

Normally when you click on that button the popup window with the poll creator will close and the poll would appear in the 'Poll:' option on the post form.

Can you try making a poll in the Test Forum on this forum and see if that works?


FUDforum Core Developer
Re: can't create/edit polls [message #3687 is a reply to message #3685] Thu, 04 July 2002 09:29 Go to previous messageGo to next message
ctbk is currently offline  ctbk   Italy
Messages: 142
Registered: April 2002
Location: Milan, Italy
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
in 'test forum' it works, when I try it on my installation I get this javascript error:

Error: uncaught exception: Permission denied to set property HTMLInputElement.value



~
~
:wq
Re: can't create/edit polls [message #3688 is a reply to message #3687] Thu, 04 July 2002 09:31 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The permission denied error says to me that your browser denies the script from performing a certain action. It probably has something to do with your browser's JaavScript security settings.

The problem, is that the browser is denying the JavaScript from setting a value of a hidden field on the post form, hence the non working polls.


FUDforum Core Developer
Re: can't create/edit polls [message #3689 is a reply to message #3688] Thu, 04 July 2002 09:37 Go to previous messageGo to next message
ctbk is currently offline  ctbk   Italy
Messages: 142
Registered: April 2002
Location: Milan, Italy
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
prottoss wrote on Thu, 04 July 2002 09:31


The problem, is that the browser is denying the JavaScript from setting a value of a hidden field on the post form, hence the non working polls.


But I use the same browser (with the same settings) and with this (http://fud.prohost.org) forum works, and with mine (http://symbola.it/fud) it doesn't!




~
~
:wq
Re: can't create/edit polls [message #3690 is a reply to message #3689] Thu, 04 July 2002 09:38 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Dunno, but permission denied error has to do with your browser and not the forum.

I know that some browsers such as Mozilla & IE allow the user to define different permissions for each site. So, you may have less restrictive permissions for fud.prohost.org then you have for symbola.it/fud.


FUDforum Core Developer
Re: can't create/edit polls [message #3692 is a reply to message #3690] Thu, 04 July 2002 09:51 Go to previous messageGo to next message
ctbk is currently offline  ctbk   Italy
Messages: 142
Registered: April 2002
Location: Milan, Italy
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I don't have any particular setting for symbola.it, and I've tried to do the same (create a poll) with Opera 6.0 too, and the problem remains.

Try to add a poll, you can use
username: ste
pass: steste


~
~
:wq
Re: can't create/edit polls [message #3693 is a reply to message #3692] Thu, 04 July 2002 09:58 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I see, I am getting the same error as you with my Mozilla.

Could you try upgrading to FUDforum 2.2.0, maybe the problem will go away, although it is unlikely since the Poll code was not modified between 2.0.2 and 2.2.0

The strangest thing is that while I clearly see the problem on you site, I cannot replicate on any other forum I have access to.


FUDforum Core Developer
Re: can't create/edit polls [message #3696 is a reply to message #3683] Thu, 04 July 2002 10:02 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
AHA!!

I think i found your problem.

You see your forum's url is www.symbola.it/fud/, however your forum has
symbola.it/fud/ as it's url. Because the domains do not match you get the JavaScript error you are seeing.
To fix the problem, go to the admin control panel and change the value of the 'WWW Root' to "http://www.symbola.it/fud/".

Then (if you are still on FUD 2.0.2) do, 'Rebuild Templates', that should fix the problem.


FUDforum Core Developer
Re: can't create/edit polls [message #3698 is a reply to message #3696] Thu, 04 July 2002 10:18 Go to previous messageGo to next message
ctbk is currently offline  ctbk   Italy
Messages: 142
Registered: April 2002
Location: Milan, Italy
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
prottoss wrote on Thu, 04 July 2002 16:02

AHA!!
I think i found your problem.


Ehm... I'm sorry but I can't see if you got the solution right...

I've upgraded to 2.2 and now it works Smile

Thanx anyway! Smile


~
~
:wq
Re: can't create/edit polls [message #3699 is a reply to message #3698] Thu, 04 July 2002 10:21 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
ctbk wrote on Thu, 04 July 2002 10:18

prottoss wrote on Thu, 04 July 2002 16:02

AHA!!
I think i found your problem.


Ehm... I'm sorry but I can't see if you got the solution right...

I've upgraded to 2.2 and now it works Smile

Thanx anyway! Smile


Ah okie, as long as it works Wink


FUDforum Core Developer
Re: can't create/edit polls [message #13441 is a reply to message #3683] Mon, 13 October 2003 15:53 Go to previous messageGo to next message
kayaker is currently offline  kayaker   United States
Messages: 15
Registered: March 2003
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I am having a similar problem. I have the latest version (downloaded last week) and my I think that my WWW_root and forum URL match.

When I go create a poll the "create" button on the pop up doesn't do anything.
Re: can't create/edit polls [message #13466 is a reply to message #13441] Mon, 13 October 2003 21:47 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Do you see any Javascript errors?

FUDforum Core Developer
No error messages [message #13474 is a reply to message #13466] Mon, 13 October 2003 22:49 Go to previous message
kayaker is currently offline  kayaker   United States
Messages: 15
Registered: March 2003
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
For the polls popup the button acts like it has been clicked, but does nothing and displays visible errors.

For the Listmaker, also no visible errors.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: external authentication
Next Topic: Error-message when running install.php
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Dec 16 19:40:24 EST 2017

Total time taken to generate the page: 0.00806 seconds