FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Converters » phpBB Converter not working
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
phpBB Converter not working [message #32011] Wed, 31 May 2006 12:28 Go to next message
Ryo2023 is currently offline  Ryo2023   Germany
Messages: 8
Registered: May 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello,
i really need help.

I want to convert my phpBB2-Forum to the FUDForum 2.7.4.

My forum-dir is domain.xyz/FUDforum/forum/
So i think that is what's called "Forum's main web Directory"

I copy the phpbb2.php-file in this directory and tried to launch it via Browser and got this message: "This script must be placed in FUDforum's main web directory."

No matter what i always get this message, i unlocked the files, i tried it from the console, but nothing works.

Please help, it would be so nice to run FUDforum instead of phpBB2.

Thank you,
Ryo
Re: phpBB Converter not working [message #32015 is a reply to message #32011] Wed, 31 May 2006 17:03 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to make sure that directory the conversion script it placed in contains GLOBALS.php file.

FUDforum Core Developer
icon4.gif  Re: phpBB Converter not working [message #32018 is a reply to message #32015] Thu, 01 June 2006 03:30 Go to previous messageGo to next message
Ryo2023 is currently offline  Ryo2023   Germany
Messages: 8
Registered: May 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Wed, 31 May 2006 23:03

You need to make sure that directory the conversion script it placed in contains GLOBALS.php file.


Hi,
yes it has a LINK to include/GLOBALS.php in it.
But i even tried to put it in FUDforum/forum/include/ with the very same result.

I hope there is a way to run this script or i have to stuck with this buggy phpBB2.

Bye
Ryo

--
Here some additional Information:

PHP built On: Linux xxxxxx 2.6.8-022stab076.4-smp #1 SMP Fri Apr 14 19:06:44 MSD 2006 x86_64
Database Version: 4.1.13
PHP Version: 4.4.0
Web Server: Apache/2.0.54 (Linux/SUSE)
WebServer to PHP interface: apache2handler
WebServer User/Group: 8 / 30
Forum Version: 2.7.4
Relavent PHP Settings:
Safe Mode: ON
Open basedir: /srv/www/vhosts/xxxxx/httpdocs:/tmp
Display Errors: OFF
File Uploads: ON
Maximum File Upload Size: 2M
Magic Quotes: OFF
Register Globals: OFF
Output Buffering: Yes
Disabled Functions: none
PSpell Support: No
Zlib Support: Yes

[Updated on: Thu, 01 June 2006 10:07]

Report message to a moderator

Re: phpBB Converter not working [message #32025 is a reply to message #32018] Thu, 01 June 2006 18:36 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
On the line which says @include("./GLOBALS.php"); remove the @ and see if you get any error messages while trying to run the conversion script.

FUDforum Core Developer
Re: phpBB Converter not working [message #32036 is a reply to message #32025] Fri, 02 June 2006 03:17 Go to previous messageGo to next message
Ryo2023 is currently offline  Ryo2023   Germany
Messages: 8
Registered: May 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Fri, 02 June 2006 00:36

On the line which says @include("./GLOBALS.php"); remove the @ and see if you get any error messages while trying to run the conversion script.


Ok, there is no change.
Same Error.

Update: I also tried to give the direct path, instead of the symbolic link "./include/GLOBALS.php". Same Error.

[Updated on: Sat, 03 June 2006 07:29]

Report message to a moderator

Re: phpBB Converter not working [message #32049 is a reply to message #32036] Sat, 03 June 2006 12:54 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Try to remove the
<?php
if ($gl === FALSE) {
                exit(
"This script must be placed in FUDforum's main web directory.\n");
        }
?>


And see if the conversion process runs.


FUDforum Core Developer
Re: phpBB Converter not working [message #32051 is a reply to message #32049] Sun, 04 June 2006 04:54 Go to previous messageGo to next message
Ryo2023 is currently offline  Ryo2023   Germany
Messages: 8
Registered: May 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Sat, 03 June 2006 18:54

Try to remove the
<?php
if ($gl === FALSE) {
                exit(
"This script must be placed in FUDforum's main web directory.\n");
        }
?>


And see if the conversion process runs.


No, the conversion process won't run.
Nothing disappear on the screen.

I also tried to make a hardlink instead of the symbolic link, with no other result.
I discovered that if i put a real copy of GLOBALS.php in the main directory nothing disappears, just like when i removed the upper code.
It seems that the File could not be read or something. I tried to read the variable $gl, but it's empty.

Does it have something to do with the safe mode ?
It's a virtual server (vServer), if that will help.

Bye
Ryo

Re: phpBB Converter not working [message #32052 is a reply to message #32051] Sun, 04 June 2006 10:25 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
If safe_mode is you may not be able to successfully run the script due to file ownership issues. If you are running the script from the webserver, you need to make a tiny little PHP script that would make a copy of the phpBB2.php and then run the copy.
Ex.

<?php
copy
("phpBB2.php""phpBB2_safe.php");
?>


FUDforum Core Developer
Re: phpBB Converter not working [message #32061 is a reply to message #32052] Mon, 05 June 2006 14:05 Go to previous messageGo to next message
Ryo2023 is currently offline  Ryo2023   Germany
Messages: 8
Registered: May 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ok.
Not even this tiny little Script worked when i upload it.
I went to the shell and chown the script by myself. And also i had to chown the whole phpbb2-directory, even while it worked with no problem.

After this everything worked fine. Only a few Users and their posts are lost, but everything else works great now.

THANKS A LOT.

Now i can work with this really nice and genius Forum. At last i am free from phpBB2...yeah !

Surprised
Re: phpBB Converter not working [message #34432 is a reply to message #32011] Sat, 28 October 2006 09:34 Go to previous messageGo to next message
Bahpoo is currently offline  Bahpoo   Costa Rica
Messages: 2
Registered: October 2006
Location: Costa Rica
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello,

I found this thread since I was getting the "This script must be placed in FUDforum's main web directory." warning as well.

When I implemented the suggestion:
Quote:

Try to remove the
<?php
if ($gl === FALSE) {
exit("This script must be placed in FUDforum's main web directory.\n");
}
?>

And see if the conversion process runs.

FUDforum Core Developer


I get this far:
Quote:


Failed to connect to database containing phpBB2 settings using MySQL information inside 'http://www.dominical.biz/forum/config.php'.


So then I implemented Ryo's instructions:
Quote:

I went to the shell and chown the script by myself. And also i had to chown the whole phpbb2-directory, even while it worked with no problem.

After this everything worked fine. Only a few Users and their posts are lost, but everything else works great now.


I'm not sure that I'm understanding the language here, but I went to the phpBB directory and chmoded it to 777, plus I 777'd the conversion script, but still get that warning about failing to connect to the database.

Any thoughts?


Ben
Re: phpBB Converter not working [message #34488 is a reply to message #34432] Sun, 05 November 2006 12:13 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to provide a file system path to config.php, not the URL to it.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: ipb 2 to fudforum
Next Topic: Convert Invision Power Board 2.0 to FUDforum
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 17 07:39:38 EDT 2017

Total time taken to generate the page: 0.00820 seconds