FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » No User CP tab - V2.7.5
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
No User CP tab - V2.7.5 [message #32249] Fri, 16 June 2006 20:25 Go to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
This is regarding the change from "User CP" to "Settings".

When I click on the new "Settings" in the top row links, it brings up what used to be my "User CP" but there is no longer a "User CP" tab displayed. The "Settings" tab does not go to the same "Settings" as the top row links, it goes to the profile (registration) settings.

So you have two links that both say "Settings", one in top row and one in user cp, that go to different places. Also, there is no link that corresponds with what used to be "User CP" in the tabs.

I noticed this code in tabs.inc:

if (_uid) {
$tablist = array(
'Settings'=>'uc',
'Settings'=>'register',

'Subscriptions'=>'subscribed',
'Referrals'=>'referals',
'Buddy List'=>'buddy_list',
'Ignore List'=>'ignore_list',
'Show Own Posts'=>'showposts&id='._uid
);

Looks like you are overwriting "Settings" and so it creates only the "register" link.
Re: No User CP tab - V2.7.5 [message #32265 is a reply to message #32249] Sun, 18 June 2006 12:50 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The only thing that happened is that the title of the User CP link had changed. Settings in the settings tab takes you to the profile settings, the settings in the user menu takes to the list of settings control panels.

FUDforum Core Developer
Re: No User CP tab - V2.7.5 [message #32269 is a reply to message #32265] Sun, 18 June 2006 13:39 Go to previous messageGo to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Sun, 18 June 2006 09:50

The only thing that happened is that the title of the User CP link had changed. Settings in the settings tab takes you to the profile settings, the settings in the user menu takes to the list of settings control panels.


There is now no tab in the "Settings" row that corresponds to the previous "User CP" tab, when before there was one. Was this done on purpose?
Re: No User CP tab - V2.7.5 [message #32283 is a reply to message #32269] Sun, 18 June 2006 21:38 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
That was a bug, the fix can be found here:
http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=11503


FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Security Leak on Uploads?
Next Topic: SQL bug in FUDforum 2.7.4
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Sep 15 16:34:29 EDT 2019

Total time taken to generate the page: 0.00655 seconds