FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » FUDforum 3.0+ » Issues upgrading from FUDforum2.6.6 to 2.7.5
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Issues upgrading from FUDforum2.6.6 to 2.7.5 [message #32534] Fri, 07 July 2006 14:01 Go to next message
duru1 is currently offline  duru1   United States
Messages: 24
Registered: September 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
After running the upgrade.php scripts we got the following error:

Checking if SQL permissions to perform the upgrade are avaliable
Disable the forum
Forum is now disabled
Beginning the file upgrade process

Warning: mkdir(/mkdir/xampp/FUDforum/errors/.backup): Permission denied in /opt/xampp/htdocs/upgrade.php on line 622

Warning: mkdir(/mkdir/xampp/FUDforum/errors): File exists in /opt/xampp/htdocs/upgrade.php on line 622
Begining to decompress the archive

Warning: fwrite(): supplied argument is not a valid stream resource in /opt/xampp/htdocs/upgrade.php on line 700

Warning: fclose(): supplied argument is not a valid stream resource in /opt/xampp/htdocs/upgrade.php on line 701

Warning: copy(/opt/xampp/FUDforum/errors/.backup/cat_cache.inc_1152217426): failed to open stream: No such file or directory in /opt/xampp/htdocs/upgrade.php on line 610
Couldn't open "/opt/xampp/FUDforum/cache/cat_cache.inc" for write


I figured that the webserver does not have permission to write to the FUDforum directory. After change the permissions of the FUDforum directory the files were able to be created but I did notice one thing the upgrade script does, it creates the file then sends data to it. This does not happen because when the files are created it is a read only file, when we change the permissions to write it's okay. After running the script again we get:



Checking if SQL permissions to perform the upgrade are avaliable
Disable the forum
Forum is now disabled
Beginning the file upgrade process
Begining to decompress the archive
Couldn't open "/opt/xampp/FUDforum/sql/def_stats_cache.sql" sql write


[Updated on: Fri, 07 July 2006 14:03]

Report message to a moderator

Re: Issues upgrading from FUDforum2.6.6 to 2.7.5 [message #32549 is a reply to message #32534] Sat, 08 July 2006 13:44 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
If those are the only errors you've received things should be fine. Ideally however you want to make sure that the directories and files mentioned in the error messages are writable by the web server user.

FUDforum Core Developer
Re: Issues upgrading from FUDforum2.6.6 to 2.7.5 [message #32582 is a reply to message #32549] Mon, 10 July 2006 11:37 Go to previous messageGo to next message
duru1 is currently offline  duru1   United States
Messages: 24
Registered: September 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
The directory and files are all writable to the webserver, why is it that when new files are created by the upgrade.php script it is created as a read only files that is our problem. How can we by pass that?
Re: Issues upgrading from FUDforum2.6.6 to 2.7.5 [message #32589 is a reply to message #32582] Mon, 10 July 2006 14:50 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
If you unlock the files in the admin control panel before running the upgrade script, this won't happen.

FUDforum Core Developer
Re: Issues upgrading from FUDforum2.6.6 to 2.7.5 [message #32601 is a reply to message #32589] Mon, 10 July 2006 20:32 Go to previous messageGo to next message
duru1 is currently offline  duru1   United States
Messages: 24
Registered: September 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
The forum's files where unlocked. But I clicked on unlocked
again and now I can not view anything my browser, it is blank. If I try to run the upgrade scripts it says the following message:

No permission to read/write to /opt/xampp/htdocs /GLOBALS.php. Please make sure this script had write access to all of the forum files.

[Updated on: Mon, 10 July 2006 20:33]

Report message to a moderator

Re: Issues upgrading from FUDforum2.6.6 to 2.7.5 [message #32627 is a reply to message #32601] Tue, 11 July 2006 17:57 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
What are the permissions of the files?

FUDforum Core Developer
Re: Issues upgrading from FUDforum2.6.6 to 2.7.5 [message #32677 is a reply to message #32627] Thu, 13 July 2006 20:24 Go to previous messageGo to next message
duru1 is currently offline  duru1   United States
Messages: 24
Registered: September 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I was able to upgrade our FUDforum to 2.7.5.
Inorder for the upgrade to take place I had to modify root's
.cshrc files (umask 027) to allow root to create writable files.
Also I had to change the ownership of htdocs dir, FUDforum dir. and everything in it to nobody:nogroup since apache is running as nobody:nogroup. I modified permissions to all .sql and .tbl files within sql, changes were made to thm/default/i18n/*/msg and chineses/charset /chineses/locale, path_info dir, etc..(all these files had read only permission) I guess my next question is what permissions should these directories and files be since it seems I have the wrong permissions and ownership.


Thanks
Re: Issues upgrading from FUDforum2.6.6 to 2.7.5 [message #32684 is a reply to message #32677] Fri, 14 July 2006 15:18 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
FUDforum files should ideally be owned by the webserver user/group and have 0600 permissions for files and 0700 for directories.

FUDforum Core Developer
Re: Issues upgrading from FUDforum2.6.6 to 2.7.5 [message #32691 is a reply to message #32684] Fri, 14 July 2006 18:37 Go to previous messageGo to next message
duru1 is currently offline  duru1   United States
Messages: 24
Registered: September 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I did not test the upgrade on our production machine but on a test box I changed the permissions to what they should be ran the upgrade and after completion when I went to the forum I just get a blank page. What caused that?

[Updated on: Fri, 14 July 2006 18:37]

Report message to a moderator

Re: Issues upgrading from FUDforum2.6.6 to 2.7.5 [message #32736 is a reply to message #32691] Mon, 17 July 2006 19:47 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you tried checking your PHP's error log? What is the permission of the index.php file?

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: HTML and FUDcode together?
Next Topic: Usability suggestions for 2.7.5 and beyond
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 21:09:30 EDT 2017

Total time taken to generate the page: 0.00738 seconds