FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » FudFOrum doesn't set proper Reply-To tags when sending mails to mailing list (Again, not FUD issue)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
FudFOrum doesn't set proper Reply-To tags when sending mails to mailing list (Again, not FUD issue) [message #32693] Fri, 14 July 2006 22:14 Go to next message
ligesh is currently offline  ligesh   India
Messages: 63
Registered: July 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user
Hi,

i have been using fud with mailing list now for nearly an year, and the stuff actually works very well.

There is a small problem though. When FUD sends a message to the mailing list, it doesn't set the REply-To unless the actual message replied to is from teh mailing list.

Actually, FUD should check the entire thread for any message that contains the Mail-Message-Id, and use the first ID while sending mails to the list. Otherwise the mailing list thread gets badly broken, and it becomes virtually impossible to keep track of what's happening.

The problem happens if people make consecutive posts in the forum without an intervening post from the mailing list. Then the last replied to message doesn't contain a MEssage-ID, and fud just mails without any "REply-To flag".

Actually this shouldnt' create that much overhead since u have to only search one single thread, and use the Mail-Message-ID of the first mail it encounters. And this will only be executed for people who want the mailing list. So totaly it won't effect the normal forum performance too.

So can this be done?

i would really appreciate this feature. Mutt with a lot of broken threads is very difficult to manage.

Thanks in advance.

[Updated on: Fri, 14 July 2006 22:52]

Report message to a moderator

Re: FudFOrum doesn't set proper Reply-To tags when sending mails to mailing list [message #32694 is a reply to message #32693] Fri, 14 July 2006 22:33 Go to previous messageGo to next message
ligesh is currently offline  ligesh   India
Messages: 63
Registered: July 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user
I think the change should be in imsg_edit.inc.t on line 485.

After this code we should have one more scan for replyto_id. The below is the existing FUD code.
 $replyto_id = q_singleval('SELECT mlist_msg_id FROM {SQL_TABLE_PREFIX}msg WHERE id='.$mtf->reply_to);



We will try once more, and do a grand sweep.
  If ($replyto_id === null) {

 $replyto_id = q_singleval("slect mlist_msg_id from msg where THREAD-ID = '$thread-id' AND mlist_msg_id != '');
}
 


So you just search that particular thread for any message that contains a mlist_msg_id. Anything will actually do. We just don't want the thread to break up, that's all.i am not really good with Db queries, so the above may not be perfectly right. But it the the idea is implementable.


[Updated on: Fri, 14 July 2006 22:39]

Report message to a moderator

Re: FudFOrum doesn't set proper Reply-To tags when sending mails to mailing list [message #32695 is a reply to message #32694] Fri, 14 July 2006 22:52 Go to previous message
ligesh is currently offline  ligesh   India
Messages: 63
Registered: July 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user


I apologize. This problem was solved long back by FUD itself setting a mail_list_id rather than wait for the mail to do so. The problem at my forum was owing to the fact that the mailing list had not yet been created when a particular post was made, and any reply to THAT particular post will come without a reply-TO, which is actually the correct behaviour.

Sorry for the confusion.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Migrating from 2.6.15 to 2.7.5, using forum-dump feature, crashes
Next Topic: Merging Topics
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Dec 14 08:07:09 EST 2017

Total time taken to generate the page: 0.00675 seconds