FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Missing Charset Content-Type declaration in NNTP Posts
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Missing Charset Content-Type declaration in NNTP Posts [message #33267] Tue, 22 August 2006 16:36 Go to next message
woody is currently offline  woody   Switzerland
Messages: 19
Registered: August 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I use fudforum in a hignly internationalized setup. So the

Content-Type: text/plain; charset=ISO-8859-1

should match what the user's style charset. As far as I have seen it is completely missing in posts done by fudforum so that non ascii characters are likely to be displayed wrongly to nntp users.

-Benoit-
Re: Missing Charset Content-Type declaration in NNTP Posts [message #33277 is a reply to message #33267] Wed, 23 August 2006 09:11 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
If the forum's charset differs from the one used in the message the message import script will attempt to convert it using iconv or mbstring if those extensions are available.

FUDforum Core Developer
Re: Missing Charset Content-Type declaration in NNTP Posts [message #33280 is a reply to message #33277] Wed, 23 August 2006 09:18 Go to previous messageGo to next message
woody is currently offline  woody   Switzerland
Messages: 19
Registered: August 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Wed, 23 August 2006 15:11

If the forum's charset differs from the one used in the message the message import script will attempt to convert it using iconv or mbstring if those extensions are available.


Hi and thanks for replying. Well in the way NNTP => Forum the conversion seams to work. It's the other way round the Charset-Definition is missing in the Postings to the News-Server.

-Benoit-
Re: Missing Charset Content-Type declaration in NNTP Posts [message #33281 is a reply to message #33280] Wed, 23 August 2006 09:19 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You could modify the code to assume that the NNTP input is in certain charset in the even one is not specified in the message itself.

FUDforum Core Developer
Re: Missing Charset Content-Type declaration in NNTP Posts [message #33283 is a reply to message #33281] Wed, 23 August 2006 09:28 Go to previous messageGo to next message
woody is currently offline  woody   Switzerland
Messages: 19
Registered: August 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Wed, 23 August 2006 15:19

You could modify the code to assume that the NNTP input is in certain charset in the even one is not specified in the message itself.


Hello Smile

It is still the other way round where the problem occures. Ok I try to be more specific...

Somebody posts a message with umlauts via WEB to the Forum.

This get's gated to the Newsgroup.

Some part of the forum code does a connect to the Newsserver and does an NNTP Post of the Article, but does not set any charset.

If some other user then reads that artice via NNTP, the client usualy assumes no charset = US-Ascii and displays 'broken' 8-Bit Characters.

Well I could look for the part of the forum code which does post the message to the NNTP Server and just hardcode a supplementary Header setting the charset to ISO-8859-1 or whatever. But that information is already present somewhere in the forum and can differ from whatever language 'theme' the user has selected, so it would probably be more appropriate to re-use that charset.

-Benoit-
Re: Missing Charset Content-Type declaration in NNTP Posts [message #33303 is a reply to message #33283] Thu, 24 August 2006 11:38 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Good point.

Content-Type header is now being added to messages synchronized to nntp, patch can be found here:

http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=11560


FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: NNTP newsgroup import with attachment
Next Topic: Tree-View / 2.76 RC1 / Non-IE-Browsers only
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 24 00:15:46 EDT 2017

Total time taken to generate the page: 0.00666 seconds