FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » 2.7.5 -> 2.7.6 Upgrade problems
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
2.7.5 -> 2.7.6 Upgrade problems [message #33770] Wed, 20 September 2006 09:20 Go to next message
pssc is currently offline  pssc   United Kingdom
Messages: 6
Registered: September 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Upgrade seemed to run ok but only admin can now login
all other users get an error:-


Warning: pg_query() [function.pg-query]: Query failed: ERROR: argument of OR must be type boolean, not type integer in /home/pssc/public_html/FUD/index.php on line 95

Fatal error: SQL Error has occurred, please contact the administrator of the forum and have them review the forum's SQL query log in
log:-
(/home/pssc/public_html/FUD/index.php:95
/home/pssc/public_html/FUD/index.php:89
/home/pssc/public_html/FUD/theme/default/index.php:151
/home/pssc/public_html/FUD/index.php:1219
) : ERROR: argument of OR must be type boolean, not type integer
Query: SELECT m.subject, m.id, m.post_stamp, u.id, u.alias, f.cat_id, f.forum_icon, f.id, f.last_post_id, f.moderators, f.name, f.descr, f.post_count, f.thread_count, fr.last_view, mo.id, COALESCE(g2.group_cache_opt, g1.group_cache_opt) AS group_cache_opt, c.cat_opt & 4 FROM fud26_t2fc_view v INNER JOIN fud26_t2cat c ON c.id=v.c INNER JOIN fud26_t2forum f ON f.id=v.f INNER JOIN fud26_t2group_cache g1 ON g1.user_id=2147483647 AND g1.resource_id=f.id LEFT JOIN fud26_t2msg m ON f.last_post_id=m.id LEFT JOIN fud26_t2users u ON u.id=m.poster_id LEFT JOIN fud26_t2forum_read fr ON fr.forum_id=f.id AND fr.user_id=4 LEFT JOIN fud26_t2mod mo ON mo.user_id=4 AND mo.forum_id=f.id LEFT JOIN fud26_t2group_cache g2 ON g2.user_id=4 AND g2.resource_id=f.id WHERE (mo.id IS NOT NULL OR (COALESCE(g2.group_cache_opt, g1.group_cache_opt)) & 1)>0 ORDER BY v.id
_GET: array ( 't' => 'index', 'SQ' => '81e16c8ae55af990c8a7d733587af380', )
Server Version:
[Referring Page] http://xxxxxxxxx/~pssc/FUD/index.php?t=login

Running:-
postgresql-7.4.13, solaris 8
Web Server: Apache/2.0.54 (Debian GNU/Linux) PHP/5.1.6-1~bpo.1
Safe mode.

Phill.
Re: 2.7.5 -> 2.7.6 Upgrade problems [message #33787 is a reply to message #33770] Thu, 21 September 2006 17:58 Go to previous message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Fixed in CVS, here is the fix:
http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=11601


FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: V2.7.5 - problem with error and sql log timestamps
Next Topic: Fold/unfold bug in 2.7.6RC2
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 10:17:26 EDT 2017

Total time taken to generate the page: 0.00596 seconds