FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Java script errors when accessing the forum
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Java script errors when accessing the forum [message #33975] Sat, 30 September 2006 06:10 Go to next message
Achil is currently offline  Achil   Belarus
Messages: 12
Registered: September 2006
Location: Prague
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have Java script errors when accessing the forum and replying to posts. http://forum.webmasterlagoon.com
Line: 2
Char: 7
Error: Invalid Character
Code: 0
I just don't get what's wrong. It happened suddenly, though it was ok before.

[Updated on: Sat, 30 September 2006 06:28]

Report message to a moderator

Re: Java script errors when accessing the forum [message #33985 is a reply to message #33975] Sat, 30 September 2006 13:27 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It appears that your lib.js file is corrupted

Error: illegal character
Source File: http://forum.webmasterlagoon.com/lib.js
Line: 1, Column: 6
Source Code:
GIF89a

Is what Firefox Javascript debugger shows me. Looking at the file reveals all manner of garbage data, that would explain the error. The solution, replace your lib.js with the one from this forum or web cvs.


FUDforum Core Developer
Re: Java script errors when accessing the forum [message #33987 is a reply to message #33985] Sat, 30 September 2006 15:14 Go to previous messageGo to next message
Achil is currently offline  Achil   Belarus
Messages: 12
Registered: September 2006
Location: Prague
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I wonder why it happened.
When I was moving to another server, I made a forum's dump then istalled it again and during the step 2 after I pressed the continue button the connection was lost. The sever had a short downtime.
When it went up again, I started the process from the step 1.
Then uploaded the dump, checked the forum for consistency. Everything was ok, utill I found this bug wiht javascript.

I'm just worried if all the rest would be Ok.
Re: Java script errors when accessing the forum [message #34010 is a reply to message #33985] Sun, 01 October 2006 11:02 Go to previous messageGo to next message
JanRei is currently offline  JanRei   Germany
Messages: 361
Registered: October 2005
Location: Germany
Karma: 0
Senior Member
Contributing Core Developer
Translator
add to buddy list
ignore all messages by this user
Ilia schrieb am Sa, 30 September 2006 19:27

It appears that your lib.js file is corrupted

Error: illegal character
Source File: http://forum.webmasterlagoon.com/lib.js
Line: 1, Column: 6
Source Code:
GIF89a

Is what Firefox Javascript debugger shows me. Looking at the file reveals all manner of garbage data, that would explain the error. The solution, replace your lib.js with the one from this forum or web cvs.

It is a bit off-topic, but this post seems to have broken the RDF feed of this forum.
Re: Java script errors when accessing the forum [message #34018 is a reply to message #33987] Sun, 01 October 2006 15:25 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It appears that some of the files were not restored correctly, one solution I'd recommend would be run the upgrade script.

FUDforum Core Developer
Re: Java script errors when accessing the forum [message #34041 is a reply to message #34018] Mon, 02 October 2006 09:56 Go to previous messageGo to next message
Achil is currently offline  Achil   Belarus
Messages: 12
Registered: September 2006
Location: Prague
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Sun, 01 October 2006 15:25

It appears that some of the files were not restored correctly, one solution I'd recommend would be run the upgrade script.


How do I do run the upgrade script?
Re: Java script errors when accessing the forum [message #34045 is a reply to message #34041] Mon, 02 October 2006 12:16 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Upload it into the forum's web dir and then access it via a web browser.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: re: Source code for FUDForum
Next Topic: how make a new theme (similar theme default)
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Sep 23 18:06:38 EDT 2018

Total time taken to generate the page: 0.00761 seconds