FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Can't install 2.7.6, call to undefined function fe()
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Can't install 2.7.6, call to undefined function fe() [message #34935] Sat, 25 November 2006 14:36 Go to next message
KC-Bill is currently offline  KC-Bill   United States
Messages: 2
Registered: November 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I keep getting the following error when trying to install FUDForum 2.7.6:
Fatal error: Call to undefined function fe() in C:\[siteroot]\forum\install.php on line 872

The line in question is in this section of code:
if (!$tbl || !$sql) {
  fe("Failed to get a list of table defenitions and/or base table data from: '{$_POST['SERVER_DATA_ROOT']}sql/'\n");
}

This happens after step 2 of 5 where I enter the MySQL database information. I can't find any reference to an "fe" function anywhere, so I don't know how to proceed...

Can anyone tell me what am I'm missing?
Re: Can't install 2.7.6, call to undefined function fe() [message #34938 is a reply to message #34935] Sat, 25 November 2006 23:41 Go to previous messageGo to next message
KC-Bill is currently offline  KC-Bill   United States
Messages: 2
Registered: November 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ok, sorry to post a reply to my own question, but I've solved this. There were two problems, one was mine and one was FUDForum's.

My problem was that FUDForum (or PHP more precisely I assume) somehow didn't like my www root directory. The root directory had both spaces and square brackets [ ] in it, not sure which of those caused the problem as I removed them both in favor of a less convoluted name. Once I simplified the directory name, it stopped trying to call the fe() function.

The part that was FUDForum's problem of course is that it was trying to call a missing function to clue me in on the directory naming error I'd made. After a little digging around, I found the file install-cli.php in the CVS, and it had both the fe() and the pf() functions in it. Putting both of those functions into my install.php made it work correctly, which got it to report to me that it couldn't read from my root directory (actually, root + 'sql/').

I take it most people would never find this issue as it only rears it's head if you have a directory name it doesn't like. FYI, my root dir was "c:\www\sitename.com [new]\".

Cool
Re: Can't install 2.7.6, call to undefined function fe() [message #34942 is a reply to message #34938] Sun, 26 November 2006 11:16 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Fixed in CVS, thanks for the analysis.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Finally going to upgrade
Next Topic: Problems intalling in install.php on line 553
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Dec 16 13:38:48 EST 2018

Total time taken to generate the page: 0.00621 seconds