FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Where is WWW Root stored?
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Where is WWW Root stored? [message #35752] Wed, 07 February 2007 10:35 Go to next message
NomadDervish is currently offline  NomadDervish   United States
Messages: 3
Registered: January 2007
Location: Minneapolis, MN
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Short version: I've mostly hosed my installation by changing WWW Root to a URI that doesn't resolve properly. This has effectively disabled the Admin Control Panel (along with everything else), so I can't change it via the normal method. Where is the WWW Root stored so that I can manually fix it?

The full story: I initially set my forum up at existingdomain.org/~me/forum until I got around to registering newdomain.com. When I did the registration, the registrar's form came up with "use my own nameservers" selected and I assumed the IP addresses that it filled in for me were, in fact, my own nameservers, the same as the other domains I had registered there. They weren't. They were the registrar's servers, which resolve everything to a default address (which doesn't even respond to HTTP requests).

I changed the nameservers to the correct values once I discovered this, but the bad address for newdomain.com had already gotten itself cached. After a couple days' wait, I was notified this morning that newdomain.com was now resolving properly, so I went off to my forum and changed the WWW Root to www.newdomain.com, since everyone seems to expect the pointless www. prefix to be there.

But, of course, www.newdomain.com is still resolving as the registrar's nonresponsive server... If I go to newdomain.com, I am able to get my forum's home, albeit with no colors or images and none of the links work, since all that stuff is looking for www.newdomain.com. It looks pretty certain to me that everything worked on the fudforum side and my only problem is that the hostname in WWW Root points to an address that resolves incorrectly. I've looked in the database, but there isn't a table named "settings" or "www_root_lives_here" or anything else that makes it obvious where to go to fix WWW Root, so here I am, hoping to find out where that's stored.
Re: Where is WWW Root stored? [message #35766 is a reply to message #35752] Wed, 07 February 2007 19:13 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This setting is stored inside the GLOBALS.php inside the include/ directory. Once you update it you'll be able to access the admin control panel by going to it directly. Once you login go to the theme manager and rebuild the theme. After this is done the forum will become fully operational.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: DELETE FROM fud26_msg_store
Next Topic: moved to a new host, now getting sql error after importing backup
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Sep 25 05:16:03 EDT 2018

Total time taken to generate the page: 0.00701 seconds