FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Installation Problems on OS X ([notice] child pid 7802 exit signal Bus error (10))
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Installation Problems on OS X [message #36071] Fri, 02 March 2007 04:21 Go to next message
fixed is currently offline  fixed   Australia
Messages: 1
Registered: March 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Using OS X 10.4, latest darwinports php5/apache2.

I've tried both the latest releases and cvs of FUDforum.

I run the install script, I put in the right install paths, hit "Next", then I get a blank page.

In my apache logs:

[Fri Mar 02 19:33:35 2007] [notice] child pid 7802 exit signal Bus error (10)

Any ideas?
Re: Installation Problems on OS X [message #36092 is a reply to message #36071] Sun, 04 March 2007 12:26 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Try using PHP source code from php.net.

FUDforum Core Developer
Re: Installation Problems on OS X [message #39901 is a reply to message #36071] Wed, 19 December 2007 17:34 Go to previous messageGo to next message
gracion is currently offline  gracion   United States
Messages: 3
Registered: December 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I had FUDForum 2.7.5 running fine on OS X 10.4.11 (client) with PHP 5.1.2 (Liyanage's entropy.ch binary) on OS X's Apache 1.3.33.

Running either the 2.7.6 or 2.7.7 installer resulted in a bus error. Since I had only used FUDForum for testing to this point, I tried to do a 2.7.7 fresh install first on 5.1.2 and then on PHP 5.2.4 (the latest binary available from entropy.ch, which seems to be very widely used on OS X). Still bus error.

Based on the earlier report of bus error with darwinports version of the php.net source, I downloaded the 5.2.5 source directly from php.net, but this has reached the point of no return (although I've done configure-make-install unix ports before, I'm not willing to spend the rest of the day learning advanced make configuration as applied to Apache-PHP plugin architecture (the default configure option "--enable-module=so" in php.net's example build instructions is not recognized, and the help text contains at least 2 more levels of information indirection I would have to dereference)). Even the PHP port experts (Liyanage and the darwinports people) haven't managed to release a 5.2.5 build or port, so I don't expect it would be trivial.

Any suggestions? It doesn't seem wise to start using FUDForum 2.7.5 if I can't install updates. Otherwise, this is a datapoint for other OS X admins.





Re: Installation Problems on OS X [message #39902 is a reply to message #39901] Wed, 19 December 2007 19:34 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I suspect that version of PHP has a bug that is being triggered by some code in the forum. If you could generate a backtrace or identify precisely which function causes an error a work-around can probably be devised.

FUDforum Core Developer
Re: Installation Problems on OS X [message #39904 is a reply to message #39902] Wed, 19 December 2007 20:12 Go to previous messageGo to next message
gracion is currently offline  gracion   United States
Messages: 3
Registered: December 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks for the reply - yes - I've got backtrace Smile Doesn't show what php code triggered it, alas. I suppose I could try cutting up the install script - let me know if there's something I can try. --Paul

0 <<00000000>> 0xffff8ac0 __memcpy + 800 (cpu_capabilities.h:189)
1 libphp5.so 0x0249e170 _php_stream_copy_to_mem + 384 ((null):-1)
2 libphp5.so 0x024383fc zif_stream_get_contents + 404 ((null):-1)
3 libphp5.so 0x0251a188 zend_do_fcall_common_helper_SPEC + 1436 ((null):-1)
4 libphp5.so 0x02521bd0 ZEND_DO_FCALL_SPEC_CONST_HANDLER + 228 ((null):-1)
5 libphp5.so 0x02519ad8 execute + 580 ((null):-1)
6 libphp5.so 0x024ea784 zend_execute_scripts + 420 ((null):-1)
7 libphp5.so 0x02481158 php_execute_script + 852 ((null):-1)
8 libphp5.so 0x02588058 apache_php_module_main + 212 ((null):-1)
9 libphp5.so 0x02589658 send_php + 740 ((null):-1)
10 libphp5.so 0x025896c8 send_parsed_php + 48 ((null):-1)
11 httpd 0x0000dd04 ap_invoke_handler + 232
12 httpd 0x00017dc0 process_request_internal + 640
13 httpd 0x00017e40 ap_process_request + 72
14 httpd 0x00006b4c child_main + 1832
15 httpd 0x00006db0 make_child + 312
16 httpd 0x00006e68 startup_children + 116
17 httpd 0x000074d8 standalone_main + 480
18 httpd 0x00007d60 main + 1052
19 httpd 0x00002388 _start + 344
20 httpd 0x0000222c start + 60

Re: Installation Problems on OS X [message #39907 is a reply to message #39904] Thu, 20 December 2007 20:24 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Looks like file_get_contents() crashed, which is rather unusual. IS there a way you could try PHP port with debug symbols?

FUDforum Core Developer
Re: Installation Problems on OS X [message #39908 is a reply to message #36071] Fri, 21 December 2007 01:02 Go to previous message
gracion is currently offline  gracion   United States
Messages: 3
Registered: December 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
macports(.org) has several variants of php, but the php debug build option is not among them, sorry. I plan to try with a newer php (php5.2.5) and possibly apache2, perhaps that will make a difference.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Integrate FUD to a php page
Next Topic: Admin password no longer recognized after upgrade
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Dec 14 08:17:19 EST 2018

Total time taken to generate the page: 0.00699 seconds