FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » error when import chinese newsgroup
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
error when import chinese newsgroup [message #36294] Wed, 14 March 2007 09:22 Go to next message
greg is currently offline  greg   China
Messages: 18
Registered: February 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have set up a Chinese newsgroup, the message are imported mysql, when the message display on the forum, it's unreadable, something like:
?ˣ?ģʇ˵???햐?ĠSYSTEM ռӃ׊Դ?߂𣿼br /> 
SYSTEM ռӃ׊Դ͹͹Ҳʇ?󌨳̐򒽷??ģ??򕟲ٗ????ɭ?ʹ攚˰????ǫ?켢r /> ?钻ςҔ??ȫģʽƴ?? 


when i add chinese from the forum to mysql(not from newsgroup), the words will save like

&#30005 &#33041 &#29233 &#22909 &#32773

Can you help me to fix it?


[Updated on: Wed, 14 March 2007 10:10]

Report message to a moderator

Re: error when import chinese newsgroup [message #36339 is a reply to message #36294] Sun, 18 March 2007 13:34 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Do you have iconv or mbstring extensions enabled?

FUDforum Core Developer
Re: error when import chinese newsgroup [message #36357 is a reply to message #36294] Sun, 18 March 2007 21:13 Go to previous messageGo to next message
greg is currently offline  greg   China
Messages: 18
Registered: February 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
yes, i have iconv, but sure what is mbsting,will check it. i have use iconv to convert the string to GBK, this way, most of string are display good, but only a few can not display.
eg
1, ................( in chinese)
2, ................( in chinese)
3,, ................( not in chinese)
4,, ................( in chinese)
5,, ................( in chinese)
6,, ................( in chinese)

I am not sure why some record can not convert to Chinese, maybe that's record has a different charset in the mysql.
why that's happens? hope you can help me.
Re: error when import chinese newsgroup [message #36369 is a reply to message #36357] Mon, 19 March 2007 19:13 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It is possible that mbstring or iconv is failing to convert certain characters.

FUDforum Core Developer
Re: error when import chinese newsgroup [message #36375 is a reply to message #36294] Mon, 19 March 2007 22:44 Go to previous messageGo to next message
greg is currently offline  greg   China
Messages: 18
Registered: February 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
if so, how to fix that? can you give me a solution?
thanks
Re: error when import chinese newsgroup [message #36386 is a reply to message #36375] Tue, 20 March 2007 19:16 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You can try to use iconv to convert the message text into the forum's charset.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: IP Browser
Next Topic: compile 32bit Mplayer on 64bit Debian's problem
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Dec 13 13:35:28 EST 2017

Total time taken to generate the page: 0.00549 seconds