FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » delete all selected - permission issue
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
delete all selected - permission issue [message #36303] Thu, 15 March 2007 11:29 Go to next message
Marticus   United States
Messages: 272
Registered: June 2002
Karma: 1
Senior Member
add to buddy list
ignore all messages by this user
It would seem that the "delete all select" button is not bound to the "delete" bit, but deleting individual topics works just fine. Is this a bug?
Re: delete all selected - permission issue [message #36349 is a reply to message #36303] Sun, 18 March 2007 14:16 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Sounds like a bug, can you try the following patch:
http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=11753


FUDforum Core Developer
Re: delete all selected - permission issue [message #36430 is a reply to message #36349] Thu, 22 March 2007 23:06 Go to previous messageGo to next message
Marticus   United States
Messages: 272
Registered: June 2002
Karma: 1
Senior Member
add to buddy list
ignore all messages by this user
Sorry it took so long to get back to you. The patch works. A related issue is that when I remove "move" permission, the "lock" link goes away as well as the check boxes. I should also note that I have the most recent stable version. mmd.php.t is 1.9 for me, not 1.10.

[Edit: patch indeed works]

[Updated on: Thu, 22 March 2007 23:17]

Report message to a moderator

Re: delete all selected - permission issue [message #36432 is a reply to message #36430] Thu, 22 March 2007 23:15 Go to previous messageGo to next message
Marticus   United States
Messages: 272
Registered: June 2002
Karma: 1
Senior Member
add to buddy list
ignore all messages by this user
Also note, when I have delete and move enabled but not lock, it shows the lock link anyway and the checkboxes are present once again. When I have Move and Lock, the Lock link and the checkboxes are missing.

Move + Delete + Lock = all is well
Delete + Lock = missing Lock link and check boxes
Delete + Move = Lock link is present
Move + Lock = missing Lock link and check boxes

Happy to test any patch you release for this and/or provide more details if needed.

[Updated on: Thu, 22 March 2007 23:22]

Report message to a moderator

Re: delete all selected - permission issue [message #36732 is a reply to message #36432] Tue, 03 April 2007 09:44 Go to previous messageGo to next message
Marticus   United States
Messages: 272
Registered: June 2002
Karma: 1
Senior Member
add to buddy list
ignore all messages by this user
Further testing:

Lock by itself = no Lock links and no check boxes no buttons
Delete by itself = Delete links but no check boxes no buttons
Move by itself = Move links but no check boxes no buttons

and as before, reconfirmed:

None = Nothing
All Three = All three links and check boxes and both "... all" buttons
Delete + Move = All three links (including Lock) and check boxes and both buttons
Delete + Lock = Delete link but neither check boxes nor buttons
Move + Lock = Move link but neither check boxes nor buttons
Re: delete all selected - permission issue [message #36738 is a reply to message #36732] Tue, 03 April 2007 20:31 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Ha? Can you elaborate on what this test supposed to mean?

FUDforum Core Developer
Re: delete all selected - permission issue [message #36807 is a reply to message #36738] Wed, 11 April 2007 00:34 Go to previous messageGo to next message
Marticus   United States
Messages: 272
Registered: June 2002
Karma: 1
Senior Member
add to buddy list
ignore all messages by this user
=D It means there is something screwy with the permissions as far as the checkboxes are concerned. If I give a user delete access only, they don't get the nifty checkboxes and the button at the bottom. If I want to give a user delete and move, they also get lock. If I want to give user only lock, they don't get the lock links.

[Updated on: Wed, 11 April 2007 00:35]

Report message to a moderator

Re: delete all selected - permission issue [message #36814 is a reply to message #36807] Wed, 11 April 2007 18:26 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Checkboxes always show up, however actions are limited by group permissions.

FUDforum Core Developer
Re: delete all selected - permission issue [message #36816 is a reply to message #36814] Thu, 12 April 2007 01:00 Go to previous messageGo to next message
Marticus   United States
Messages: 272
Registered: June 2002
Karma: 1
Senior Member
add to buddy list
ignore all messages by this user
Links also show up when they don't have permission?
Re: delete all selected - permission issue [message #36829 is a reply to message #36816] Thu, 12 April 2007 17:45 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
In this case, yes.

FUDforum Core Developer
Re: delete all selected - permission issue [message #36892 is a reply to message #36829] Sun, 15 April 2007 19:47 Go to previous message
Marticus   United States
Messages: 272
Registered: June 2002
Karma: 1
Senior Member
add to buddy list
ignore all messages by this user
This can be confusing for the people with a subset of moderator permissions. I don't think links should be available if they don't have the permission to use them. I think links -should- be available if they -do- have permission to use them. As it is now, I pretty much need to give all three permissions in order for them to have access to the one they need.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Can't even make my first post in my brand new forum
Next Topic: PHP Notice in Group(s) Manager
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Dec 17 20:10:57 EST 2017

Total time taken to generate the page: 0.00737 seconds