FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » 2.7.6: Link to "new in topic" from topic list often only shows first post...
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
2.7.6: Link to "new in topic" from topic list often only shows first post... [message #36443] Sat, 24 March 2007 07:16 Go to next message
WhiteFire is currently offline  WhiteFire   United States
Messages: 16
Registered: March 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
And just the first post, not the message that is new, and not even the rest of the thread. Any ideas what is causing this? Work arounds? It's very annoying. It makes the link useless.

Next time I catch it doing it I'll try and save the link so you can see what it is generating. Just hoping it's a known problem with an easy fix. Smile

Started when I upgraded to 2.7.6 from. Um. 2.5.2, fairly sure anyway.

Ah, here is an example:

http://www.fur.com/tapestries/forum/index.php?t=msg&th=1282&unread= 1&S=<snip>#msg_9541

Taking out the "unread=1" from the URL seems to make it work right, but that's probably not right, may not work on a muti-page one? Any idea whats up with this?

It's happening fairly often in my forums. Sad

[Updated on: Sat, 24 March 2007 08:38]

Report message to a moderator

Re: 2.7.6: Link to "new in topic" from topic list often only shows first post... [message #36450 is a reply to message #36443] Sat, 24 March 2007 12:02 Go to previous messageGo to next message
Marticus   United States
Messages: 272
Registered: June 2002
Karma: 1
Senior Member
add to buddy list
ignore all messages by this user
While that link seems works for me (it goes to the middle of the thread) I have experienced similar issues. Sometimes I find that it does not go to the first unread in an existing thread. Other times it does. I have no explanation for this behavior except for maybe something to do with the browser. See if it works from a test account as well as a different browser.
Re: 2.7.6: Link to "new in topic" from topic list often only shows first post... [message #36468 is a reply to message #36443] Sat, 24 March 2007 20:51 Go to previous messageGo to next message
WhiteFire is currently offline  WhiteFire   United States
Messages: 16
Registered: March 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
That link can't be tested directly by someone since it is reliant on what your account considers 'new' I think.

If the forums don't work w/ firefox, they are going to be pretty much a wash for me... and I don't see how a URL is going to generate a different response from the server based on the browser I'm using.
Re: 2.7.6: Link to "new in topic" from topic list often only shows first post... [message #36469 is a reply to message #36443] Sun, 25 March 2007 00:17 Go to previous messageGo to next message
WhiteFire is currently offline  WhiteFire   United States
Messages: 16
Registered: March 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I just realized that after this happens, if I reload the broken page, it comes out correctly the second try. Maybe that's a clue?
Re: 2.7.6: Link to "new in topic" from topic list often only shows first post... [message #36478 is a reply to message #36443] Sun, 25 March 2007 11:28 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The unread option only shows not-yet-read messages inside topics.

FUDforum Core Developer
Re: 2.7.6: Link to "new in topic" from topic list often only shows first post... [message #36526 is a reply to message #36478] Wed, 28 March 2007 10:05 Go to previous messageGo to next message
WhiteFire is currently offline  WhiteFire   United States
Messages: 16
Registered: March 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Sun, 25 March 2007 08:28

The unread option only shows not-yet-read messages inside topics.

Yes, then, why is it only showing the first message in the topic? And why do I get a different result when I reload the page?
Re: 2.7.6: Link to "new in topic" from topic list often only shows first post... [message #36547 is a reply to message #36526] Thu, 29 March 2007 20:14 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It works fine on this forum, can you give me detailed steps that I can use to replicate the problem?

FUDforum Core Developer
Re: 2.7.6: Link to "new in topic" from topic list often only shows first post... [message #36756 is a reply to message #36547] Fri, 06 April 2007 15:30 Go to previous messageGo to next message
WhiteFire is currently offline  WhiteFire   United States
Messages: 16
Registered: March 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Yes, I am aware that it works fine on this forum. It's really simple to reproduce on mine:

In a topic list, click on the arrow for the latest new post in the topic, or, the arrow in the last post column. Something like 90% of the time it will show only the first message in the thread, rather than all of them and going to the message in question.

Reloading the page at that point will get the entire set of messages and take you to the correct one.

Re: 2.7.6: Link to "new in topic" from topic list often only shows first post... [message #36760 is a reply to message #36443] Sat, 07 April 2007 03:09 Go to previous messageGo to next message
WhiteFire is currently offline  WhiteFire   United States
Messages: 16
Registered: March 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Compacting the message body files, and THEN running consistency followed by SQL optimizations, in that order, seems to have fixed the problem.

I had done the last two before after the last upgrade, I had not compacted before. But it seemed to need to be in that order for some reason.
Re: 2.7.6: Link to "new in topic" from topic list often only shows first post... [message #36772 is a reply to message #36756] Sun, 08 April 2007 11:31 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Just doing the consistency check should be enough, the compacting of messages only allows you to recover a little bit of disk space.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Private Message Email Link
Next Topic: Slow posting
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Dec 11 23:47:53 EST 2017

Total time taken to generate the page: 0.00752 seconds