FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Converters » Another Phorum to FUD problem
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Another Phorum to FUD problem [message #4481] Sat, 27 July 2002 20:07 Go to next message
Lupetto is currently offline  Lupetto   Italy
Messages: 9
Registered: July 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
At this time, i'm importing data from Phorum 3.3.2c with the help of the converter but i continue to get this error:

-----------------------------------

Importing Categories
CATEGORY NAME
query failed: %( INSERT INTO fud21_cat (id,name,view_order) VALUES(6,'CATEGORY NAME',1) )% because %( Table 'PHORUM_DB_NAME.fud21_cat' doesn't exist )%

------------------------------------

The query is right as everyone can see, but the function who execute it seems to prepend the name of the phorum db to the FUD table....


Do I have to offer more information?

Bye Shocked
Re: Another Phorum to FUD problem [message #4485 is a reply to message #4481] Sun, 28 July 2002 01:21 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I think you maybe affected by an 'interesting' bug in PHP, are you using 2 different databases for phorum and fudforum? If so, make sure they use different connect lines. Ex. if one uses :/tmp/mysql.sock as the sever make the other use 127.0.0.1 as MySQL server.

FUDforum Core Developer
Re: Another Phorum to FUD problem [message #4489 is a reply to message #4485] Sun, 28 July 2002 10:38 Go to previous messageGo to next message
Lupetto is currently offline  Lupetto   Italy
Messages: 9
Registered: July 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
There is another way to resolve this problem: i've created another user 'root' who can connect to '127.0.0.1' instead of 'localhost'. I mean: phorum connects to 127.0.0.1 and FUD to localhost

Now there is another strange situation...

-------------------------

Importing Categories
<CATEGORY NAME>
Finished Importing (1) Categories
Importing Forums 0
<FORUM01>
<FORUM02>
<FORUM03>
<FORUM04>
<FORUM05>
Finished Importing Forums
Unknown column 'login' in 'group statement'

-------------------------------

I'm sure i've read something similar somewhere, i'll take a look.
Re: Another Phorum to FUD problem [message #4490 is a reply to message #4489] Sun, 28 July 2002 11:33 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This is actually a bug in conversion script.

Attached is a patched version.

Ilia
  • Attachment: phorum.php
    (Size: 13.77KB, Downloaded 491 times)


FUDforum Core Developer
Re: Another Phorum to FUD problem [message #4491 is a reply to message #4490] Sun, 28 July 2002 13:34 Go to previous messageGo to next message
Lupetto is currently offline  Lupetto   Italy
Messages: 9
Registered: July 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
It works very well, but....
if i choose '$MAKE_ANON_ACCOUNTS = TRUE' i find only a single user.

Maybe now i sohuld be able to fix it.

Thanks
Re: Another Phorum to FUD problem [message #4492 is a reply to message #4491] Sun, 28 July 2002 14:38 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Hmm, that's unusual, does your phorum have many unregistered users?

FUDforum Core Developer
Re: Another Phorum to FUD problem [message #4493 is a reply to message #4492] Sun, 28 July 2002 15:53 Go to previous message
Lupetto is currently offline  Lupetto   Italy
Messages: 9
Registered: July 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
many unregistered users" are not the right words... they are all unregistered!

Maybe this is the problem, the forum i'm trying to convert is based on a already converted version of phorum that didn't support registered users.

Bye
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: help me!
Next Topic: Converting Ikonboard --> FUD
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Dec 17 16:42:02 EST 2017

Total time taken to generate the page: 0.00802 seconds