FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Problems with german Umlaut in tree-view and AJAX
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Problems with german Umlaut in tree-view and AJAX [message #37218] Mon, 14 May 2007 19:59 Go to next message
Xonk is currently offline  Xonk   Germany
Messages: 67
Registered: March 2004
Karma: 0
Member
add to buddy list
ignore all messages by this user
Hi,

some users of my site reported, that they have problems with the german Umlaut in the forum.
It seems, that it only affects, when a posting is loaded in the tree-view via AJAX.
When the page is first loaded, the first entry is displayed correct.
I can not reprocduce this, but this behaviour shall exist with some versions of FF and IE 6.

I just tried this: Changed the charset to UTF-8. After rebuilding the theme, on the start-page of the forum and the first page of each thread the umlauts are broken (I'm working with ISO-8859-15 before this test).
When I now click the link to a posting of the thread (even the first, which is displayed), the Umlauts are correct.

Is it possible, that with AJAX the charset is ignored and some browsers (or OS) habe problems with this?

Can I turn off the loading of a posting via Javascript?

Thanks & Greets,

Sven
Re: Problems with german Umlaut in tree-view and AJAX [message #37274 is a reply to message #37218] Thu, 17 May 2007 06:17 Go to previous message
Xonk is currently offline  Xonk   Germany
Messages: 67
Registered: March 2004
Karma: 0
Member
add to buddy list
ignore all messages by this user
It seems the same problem as discussed here.

I'm using 2.7.7RC1 and the tree_msg.php is the correct version.

Greets,

Sven
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: need help with sorting by category - FLAT FILE
Next Topic: Tree view issues
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 15:43:16 EDT 2017

Total time taken to generate the page: 0.00516 seconds