FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » First empty categories are visible
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
First empty categories are visible [message #37504] Wed, 30 May 2007 15:16 Go to next message
syl20 is currently offline  syl20   France
Messages: 7
Registered: January 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi,

I've got a bunch of forums that are put in 2-level subcategories.

When these forums are not visible for the connected user, the empty categories and subcategoies are visible, despite they are empty, because no forums are visible in them.

In fact these empty subcategories are only visible if the category that contains them is at the top position :

Here cat1, subcat1, subcat2 are visible, even with no visible forum in them :
- cat1
   |
   +- subcat1
   +- subcat2
+ cat2


Here cat1, subcat1, subcat2 are not visible :
+ cat2
- cat1
   |
   +- subcat1
   +- subcat2


I'm using the last stable version. I tried to rebuild themes and check consistency without any suscess.

Anyone have seen this bug ?

Thanks,
Sylvain
Re: First empty categories are visible [message #37716 is a reply to message #37504] Sun, 17 June 2007 10:52 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
What version of the forum are you using? I can't seem to replicate the problem in latest CVS.

FUDforum Core Developer
Re: First empty categories are visible [message #37789 is a reply to message #37716] Mon, 25 June 2007 15:21 Go to previous messageGo to next message
syl20 is currently offline  syl20   France
Messages: 7
Registered: January 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I'm using latest stable release, 2.7.6.

In fact, I've got several errors with empty categories (because of insufficient group privileges).

I can get empty categories even in the middle of the page.

Sylvain.
Re: First empty categories are visible [message #37865 is a reply to message #37789] Tue, 26 June 2007 20:39 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you tried running the consistency checker?

FUDforum Core Developer
Re: First empty categories are visible [message #37870 is a reply to message #37865] Wed, 27 June 2007 03:07 Go to previous messageGo to next message
syl20 is currently offline  syl20   France
Messages: 7
Registered: January 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
yes, I tried that without any success.

Moreover, creating a new subcategory, an other subtree of categories came at the toplevel, first place.

Could you explain how and where it's computed in the source. It isn't very clear for me. I've got a Zend Platform so I could step-by-step trace this code.

Regards,
Sylvain
Re: First empty categories are visible [message #38280 is a reply to message #37870] Mon, 30 July 2007 10:32 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The admin panel generates a helper PHP file that is then used in conjunction with the database to render the category listing. The helper filter contains the rendering tree and this is used to determine the layout of the categories on the page.

FUDforum Core Developer
Aw: First empty categories are visible [message #168690 is a reply to message #37504] Fri, 28 June 2013 04:54 Go to previous message
captain picard is currently offline  captain picard   Austria
Messages: 15
Registered: March 2013
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello,

same problem here, I am using version 3.0.4!

I think it looks like a bug:
emtpy sub-categories should not look up when no privileges on any contained forum are given! this tells people only "there is something more what YOU just can't see" Razz no good ^^

some questions..

Has someone a hint where the code is located for building the helper php?

Maybe you can please describe it a bit, how is it done, to determine which catergory will be visible in case it SHOULD BE..? i'll try to fix it - as i have
.no clue about SQL
.seen you're using quite an intelligent bunch of it...!
Razz

thanks in advance!
David

[Updated on: Fri, 28 June 2013 07:57]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Forum datadump failing
Next Topic: Upgrade killed the forum
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Dec 11 04:41:23 EST 2017

Total time taken to generate the page: 0.00700 seconds