FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Undefined offset bug (Undefined offset: 1 in .../theme/default/index.php on line 34)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Undefined offset bug [message #37679] Thu, 14 June 2007 20:38 Go to next message
grigori is currently offline  grigori   Ukraine
Messages: 15
Registered: June 2007
Location: Ukraine
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

Hi, it does not work for me when I click the category title.
When I turn on php_flag display_errors, it writes me
"Undefined offset: 1 in .../theme/default/index.php on line 34"

And really, in index.php.t
if ($cat_id && $collapse[$cat_id])

should be rewritten like
if ($cat_id && !empty($collapse[$cat_id]))


then it works.


P.S. I really liked reading the code Smile

WBR, Grigori

[Updated on: Fri, 15 June 2007 09:25]

Report message to a moderator

Re: Undefined offset bug [message #37715 is a reply to message #37679] Sun, 17 June 2007 10:42 Go to previous message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The bug was fixed in CVS, thanks.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Apache server - anwar khan auctions
Next Topic: tags_to_html() Bug
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Oct 22 04:04:31 EDT 2017

Total time taken to generate the page: 0.00662 seconds