FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » FUDforum 2.6.0 with MySQL 5.0.38 :: Installation Failed
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
FUDforum 2.6.0 with MySQL 5.0.38 :: Installation Failed [message #37788] Mon, 25 June 2007 14:33 Go to next message
sugog4 is currently offline  sugog4   France
Messages: 2
Registered: June 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello,
i try to install FUDforum 2.6.0 with MySQL 5.0.38(Ubuntu 7.04 Feisty Fawn server).

During Installation, Step 2, i have this message :

The specified MySQL server is running version "0", which is older then the minimum required version "3.23.0"

I've identified the code in Install.php which starts at line 752 :

$r = dbquery('SELECT VERSION()') ...

followed by a pregmatch which can't match my MySQL version, line 754 :

preg_match('!((3|4|7)\.([0-9])+)(\.([0-9]))?)!',@current($fetch($r)),$m))

then my message line 760 ...

My problem is, i have to dev an eggdrop which have to be capable of display stuff like 10last topics, new posts real time, etc based on FUDforum 2.6.0 MySQL table architecture, and i can't work on the serv where this forum is hosted : i'll just pass the code when i'm done on my local testing environement.

I see 2 solutions :

1 - table architecture has not changed since FUDforum 2.6.0, and then i can install the lastest stable release.
Am i right?

2 - i could make a little hack in the preg_match line 754 in install.php to accept my MySQL version(5.0.38).
Do you allow me to do that? and will it work?

thanks for your reading

sugog4



[Updated on: Mon, 25 June 2007 15:00]

Report message to a moderator

Re: FUDforum 2.6.0 with MySQL 5.0.38 :: Installation Failed [message #37791 is a reply to message #37788] Mon, 25 June 2007 21:26 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This is already fixed in 2.7 version of the code.

The regex was changed to '!([3-8]\.[0-9]+(?:\.[0-9]+)?)!'


FUDforum Core Developer
Re: FUDforum 2.6.0 with MySQL 5.0.38 :: Installation Failed [message #37873 is a reply to message #37788] Wed, 27 June 2007 12:14 Go to previous messageGo to next message
sugog4 is currently offline  sugog4   France
Messages: 2
Registered: June 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks for your fast answer Ilia.

now i got this message, step 2 :

Failed to import default data ("INSERT INTO fud26_cat (name,description,cat_opt,view_order) VALUES ('Test Category', ' - Just a test category', 1|2, 1)") into table def_cat, SQL Reason: Table 'homeland.fud26_cat' doesn't exist

Although the installation process has created 47 tables in my database, the fud26_cat table is missing, and i had not any failed creation table message.

I'm perplex Smile

sugog4



[Updated on: Wed, 27 June 2007 12:14]

Report message to a moderator

Re: FUDforum 2.6.0 with MySQL 5.0.38 :: Installation Failed [message #37883 is a reply to message #37873] Thu, 28 June 2007 18:55 Go to previous message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Can you try installing it into a fresh database or removing all existing tables and re-running the installer?

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: MySQL? problems with V2.7.7rc2
Next Topic: Forum move without datadump
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Apr 25 02:34:09 EDT 2018

Total time taken to generate the page: 0.00492 seconds