FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » ORIG_PATH_INFO and PHP5.2 (In new version of PHP $_SERVER['PATH_INFO'] variable is not set)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
ORIG_PATH_INFO and PHP5.2 [message #38194] Tue, 24 July 2007 10:21 Go to next message
alextop is currently offline  alextop   Ukraine
Messages: 4
Registered: September 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
In new version of PHP running in CGI mode
$_SERVER['PATH_INFO']
variable often is not set, instead it sets
$_SERVER['ORIG_PATH_INFO'] 
variable.

I offer to add such check in FUDforum so it can use either PATH_INFO or ORIG_PATH_INFO, if needed.

It can be fixed by adding cgi.fix_pathinfo = 0 in custom php.ini (if allowed) or use the trick in GLOBALS.php that sets PATH_INFO if it is not available.
Re: ORIG_PATH_INFO and PHP5.2 [message #38197 is a reply to message #38194] Tue, 24 July 2007 18:27 Go to previous message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
A patch to handle this is now in the CVS.

Thanks.


FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: PHP Notice in error_log
Next Topic: 10000 message was died
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Dec 16 08:13:27 EST 2017

Total time taken to generate the page: 0.00664 seconds