FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Undefined template: "TEMPLATE" inside " footer_lnk" (Bug when editing templates.)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
icon5.gif  Undefined template: "TEMPLATE" inside " footer_lnk" [message #38472] Wed, 08 August 2007 11:26 Go to next message
Krister461 is currently offline  Krister461   Norway
Messages: 3
Registered: August 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi,

I'm fairly new to FUDforum.

But, I've got a forum running that has worked perfectly for some time. But, today when using Template Editor, I started to get the error-message in the title.

The message comes whenever I try to hit save, independent of which template I try to edit.

I also get the message no and then while in Theme Manager, for example while trying to rebuild the theme.


When i upgraded 2.7.6 to 2.7.7RC2 I was able to change two or three templates before the error message came back. But, now I can't get it away...

any ideas?
Re: Undefined template: "TEMPLATE" inside " footer_lnk" [message #38486 is a reply to message #38472] Thu, 09 August 2007 20:02 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The error comes from the fact that on any save action the forum tries to rebuild the theme and the process raises the error. You need to edit the template containing "footer_lnk" and fix the broken TEMPLATE tag within.

FUDforum Core Developer
Re: Undefined template: "TEMPLATE" inside " footer_lnk" [message #38490 is a reply to message #38486] Fri, 10 August 2007 02:24 Go to previous messageGo to next message
Krister461 is currently offline  Krister461   Norway
Messages: 3
Registered: August 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thank you for your reply.

However, I've never edited the "footer_lnk". It looks like this:
"{ROOT}?t=index&{DEF: _rsid}"

I have edited the footer, the header and the forumcss. But it doesn't help to undo the edits there either.

Kind regards,
Krister
Re: Undefined template: "TEMPLATE" inside " footer_lnk" [message #38523 is a reply to message #38490] Sun, 12 August 2007 13:19 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
try replacing your footer.tmpl with the one in CVS.

http://cvs.prohost.org/c/index.cgi/FUDforum/getfile/install/forum_data/thm/ default/tmpl/footer.tmpl?v=1.18


FUDforum Core Developer
icon14.gif  Re: Undefined template: "TEMPLATE" inside " footer_lnk" [message #38530 is a reply to message #38523] Mon, 13 August 2007 03:33 Go to previous message
Krister461 is currently offline  Krister461   Switzerland
Messages: 3
Registered: August 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thank you very much.

Replacing the main-section of the footer solved the problem.

(I had tried to set it back to what it was, but I'd probably set it back to an older version of FUDforum).
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Automatic cleanup isn't working (V2.7.7rc2)
Next Topic: Compact forum entry
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 13:27:54 EDT 2017

Total time taken to generate the page: 0.00713 seconds