FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » SQL Error has occurred
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
SQL Error has occurred [message #39190] Tue, 09 October 2007 02:46 Go to next message
derek is currently offline  derek   United Kingdom
Messages: 21
Registered: May 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Not sure if this is linked to post below

http://fudforum.org/forum/index.php?t=msg&goto=27149&&srch=Quer y+failed%3A+ERROR%3A+parser%3A+parse+error+at+or+near+%22ORDER%22#msg_27149

but user gets this message

Warning: pg_query() [function.pg-query]: Query failed: ERROR: parser: parse error at or near "ORDER" at character 864 in /docs/forum/index.php on line 95

Fatal error: SQL Error has occurred, please contact the administrator of the forum and have them review the forum's SQL query log in FUDforum/include/core.inc on line 188

- the error seems to be 'UNABLE TO WRITE TO SQL LOG FILE'

I'm running version 2.7.6
I'm using PostgreSQL 7.3.3

Any ideas why this might have happened and how to stop it happening again? I've asked the user what they were doing at the time of the error message.

Thanks

Derek

[Updated on: Tue, 09 October 2007 07:05]

Report message to a moderator

Re: SQL Error has occurred [message #39192 is a reply to message #39190] Tue, 09 October 2007 09:05 Go to previous message
derek is currently offline  derek   United Kingdom
Messages: 21
Registered: May 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Additional info from the FUDforum/errors/sql_errors file:


?1503      ?1191934543?(docs/forum/index.php:95<br />
docs/forum/index.php:89<br />
docs/forum/theme/default/index.php:152<br />
docs/forum/index.php:1219<br />
) : ERROR:  parser: parse error at or near "ORDER" at character 864<br />
Query: SELECT
                                m.subject, m.id, m.post_stamp,
                                u.id, u.alias,
                                f.cat_id, f.forum_icon, f.id, f.last_post_id, f.moderators, f.name, f.descr, f.post_count, f.thread_count,
                                fr.last_view, mo.id, COALESCE(g2.group_cache_opt, g1.group_cache_opt) AS group_cache_opt,
                                (c.cat_opt &amp; 4) = 4
                        FROM fud25_fc_view v
                        INNER JOIN fud25_cat c ON c.id=v.c
                        INNER JOIN fud25_forum f ON f.id=v.f
                        INNER JOIN fud25_group_cache g1 ON g1.user_id=2147483647 AND g1.resource_id=f.id
                        LEFT JOIN fud25_msg m ON f.last_post_id=m.id
                        LEFT JOIN fud25_users u ON u.id=m.poster_id  LEFT JOIN fud25_forum_read fr ON fr.forum_id=f.id AND fr.user_id=13 LEFT JOIN fud25_mod mo ON mo.user_id=13 AND mo.forum_id=f.id LEFT JOIN fud25_group_cache g2 ON g2.user_id=13 AND g2.resource_id=f.id WHERE  (mo.id IS NOT NULL OR ((COALESCE(g2.group_cache_opt, g1.group_cache_opt) &amp; 1 &gt; 0)) ORDER BY v.id<br />
_GET: array (
  't' =&gt; 'index',
  'rid' =&gt; '13',
  'S' =&gt; 'b1c66e1b7dbc5c387f04d291aad9db58',
)



Seems as though the error occurs when following a new user link from an email, or while logged in and the user clics on 'Home' (but they can read/post OK).

Any advice very welcome... thanks

Derek

[Updated on: Tue, 09 October 2007 11:45]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: non-standard postgres port
Next Topic: Can't upgrade
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Oct 21 06:26:01 EDT 2018

Total time taken to generate the page: 0.00660 seconds