FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » problems after migration
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
problems after migration [message #39652] Thu, 15 November 2007 12:57 Go to next message
andy_scouser is currently offline  andy_scouser   United Kingdom
Messages: 76
Registered: June 2003
Karma: 1
Member
add to buddy list
ignore all messages by this user
Hello chaps,

Probably a bone question but, I need to move my forum to another server soon so I have been doing some testing.

I installed 2.7.7 (non zl) on the new server (zl) in 'live'
mysql 4.0.13max on old 4.0.24-log on new. (vanilla solaris 10 x86)
temporarily set local host files to lie about hostname, to match production.
Installed forum and all was well, showing temp forum etc.

Then i imported data from 'live' and after import it complained of admin user not matching on new build. I did install the forum using the same account as last time with the same passowrd.

i have checked account on old and new and the encrypted password looks fine.
The cookie i am getting form the new build looks fine
Nothing in the FUDforum errors section of the new install either apart from when i try and hit the front page....i get


?616 ?1195149083?(/var/apache2/honda_htdocs/index.php:75<br />
/var/apache2/honda_htdocs/index.php:314<br />
/var/apache2/honda_htdocs/theme/default/index.php:41<br />
/var/apache2/honda_htdocs/index.php:1198<br />
) 1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1<br />
Query: UPDATE honda_ses SET sys_id='81db1c15aa19e7f670ec5e5334b4c7be', forum_id=0, time_sec=1195149083, action='Browsing the &lt;a h
ref=\&quot;index.php?t=index\&quot;&gt;forum list&lt;/a&gt;', returnto='' WHERE id=<br />
Server Version: 4.0.24-log<br />

I can't log in to run the consistancy checker.

Can you please let me know i can look next?

Thanks all.
Re: problems after migration [message #39653 is a reply to message #39652] Thu, 15 November 2007 13:05 Go to previous messageGo to next message
andy_scouser is currently offline  andy_scouser   United Kingdom
Messages: 76
Registered: June 2003
Karma: 1
Member
add to buddy list
ignore all messages by this user
No Message Body

[Updated on: Thu, 15 November 2007 13:07]

Report message to a moderator

Re: problems after migration [message #39654 is a reply to message #39653] Thu, 15 November 2007 14:09 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Clear our your browser's cookies and try again. Also clear out the sessions table (honda_ses) just to be sure as well.

FUDforum Core Developer
Re: problems after migration [message #39655 is a reply to message #39654] Thu, 15 November 2007 14:36 Go to previous messageGo to next message
andy_scouser is currently offline  andy_scouser   United Kingdom
Messages: 76
Registered: June 2003
Karma: 1
Member
add to buddy list
ignore all messages by this user
Thanks for that, tried it, no difference Sad
Is there any information I can offer to help at all?

All im getting is when trying to get into the admloginusr.php is

Only administrators with proper access credentials can login via this control panel

Forum main page still giving original error
Fatal error: SQL Error has occurred, please contact the administrator of the forum and have them review the forum's SQL query log in /var/apache2/honda_FUDforum/include/core.inc on line 188

Thanks.

[Updated on: Thu, 15 November 2007 14:54]

Report message to a moderator

Re: problems after migration [message #39658 is a reply to message #39655] Fri, 16 November 2007 06:52 Go to previous messageGo to next message
andy_scouser is currently offline  andy_scouser   United Kingdom
Messages: 76
Registered: June 2003
Karma: 1
Member
add to buddy list
ignore all messages by this user
Im going through the whole process again... step by step.
I get the 30s php error, so i ran from command line.

Does my dump look good to use, I get a few errors.


forum# /forum/php/bin/php admdump.php /opt/backup.latest
PHP Notice: Undefined index: REMOTE_ADDR in /forum/httpd/FUDforum/include/adm_cli.inc on line 14
PHP Warning: fud_use(/forum/httpd/FUDforum/include/theme/default/adm.inc): failed to open stream: No such file or directory in /forum/httpd/FUDforum/include/core.inc on line 68
PHP Warning: fud_use(): Failed opening '/forum/httpd/FUDforum/include/theme/default/adm.inc' for inclusion (include_path='.:/forum/php/lib/php') in /forum/httpd/FUDforum/include/core.inc on line 68
PHP Notice: Use of undefined constant _rsidl - assumed '_rsidl' in /forum/httpd/FUDforum/include/adm.inc on line 20
PHP Notice: Undefined index: sq in /forum/httpd/FUDforum/include/adm.inc on line 20
PHP Notice: Use of undefined constant _rsidl - assumed '_rsidl' in /forum/httpd/FUDforum/include/adm.inc on line 21
PHP Notice: Undefined index: sq in /forum/httpd/FUDforum/include/adm.inc on line 21
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/1999/REC-html401-19991224/loose.dtd">
<html>
<head>
<title>honda-forums.com: Admin Control Panel</title><link rel="StyleSheet" href="adm.css" type="text/css">
<meta http-equiv="Content-Type" content="text/html; charset=PHP Notice: Undefined property: theme_name in /forum/httpd/htdocs/adm/admpanel.php on line 7
PHP Notice: Undefined property: lang in /forum/httpd/htdocs/adm/admpanel.php on line 7
PHP Notice: Undefined property: lang in /forum/httpd/htdocs/adm/admpanel.php on line 9
us-ascii">
</head>
<body>
<table class="maintable">
<tr>
PHP Notice: Undefined variable: is_a in /forum/httpd/htdocs/adm/admpanel.php on line 19
<td class="maindata">
Compressing forum datafiles<br>
Processing directory: /forum/httpd/FUDforum<br>PHP Notice: Use of undefined constant GLOB_BRACE - assumed 'GLOB_BRACE' in /forum/httpd/htdocs/adm/admdump.php on line 29
Processing directory: /forum/httpd/htdocs/images<br>PHP Notice: Use of undefined constant GLOB_BRACE - assumed 'GLOB_BRACE' in /forum/httpd/htdocs/adm/admdump.php on line 29
Processing directory: /forum/httpd/htdocs/adm<br>PHP Notice: Use of undefined constant GLOB_BRACE - assumed 'GLOB_BRACE' in /forum/httpd/htdocs/adm/admdump.php on line 29
Processing table: fud25_action_log (46) .... DONE<br>
Processing table: fud25_ann_forums (4) .... DONE<br>
Processing table: fud25_announce (2) .... DONE<br>
Processing table: fud25_attach (6475) .... DONE<br>
Processing table: fud25_avatar (0) .... DONE<br>
Processing table: fud25_blocked_logins (0) .... DONE<br>
Processing table: fud25_buddy (196) .... DONE<br>
Processing table: fud25_cat (5) .... DONE<br>
Processing table: fud25_custom_tags (1) .... DONE<br>
Processing table: fud25_email_block (0) .... DONE<br>
Processing table: fud25_ext_block (17) .... DONE<br>
Processing table: fud25_fc_view (24) .... DONE<br>
Processing table: fud25_forum (26) .... DONE<br>
Processing table: fud25_forum_notify (16) .... DONE<br>
Processing table: fud25_forum_read (6968) .... DONE<br>
Processing table: fud25_geoip (0) .... DONE<br>
Processing table: fud25_group_cache (52) .... DONE<br>
Processing table: fud25_group_members (52) .... DONE<br>
Processing table: fud25_group_resources (26) .... DONE<br>
Processing table: fud25_groups (28) .... DONE<br>
Processing table: fud25_index (450100) .... DONE<br>
Processing table: fud25_ip_block (5) .... DONE<br>
Processing table: fud25_level (28) .... DONE<br>
Processing table: fud25_mime (43) .... DONE<br>
Processing table: fud25_mlist (0) .... DONE<br>
Processing table: fud25_mod (40) .... DONE<br>
Processing table: fud25_mod_que (0) .... DONE<br>
Processing table: fud25_msg (147024) .... DONE<br>
Processing table: fud25_msg_report (0) .... DONE<br>
Processing table: fud25_msg_store (0) .... DONE<br>
Processing table: fud25_nntp (0) .... DONE<br>
Processing table: fud25_pmsg (5217) .... DONE<br>
Processing table: fud25_poll (139) .... DONE<br>
Processing table: fud25_poll_opt (744) .... DONE<br>
Processing table: fud25_poll_opt_track (2733) .... DONE<br>
Processing table: fud25_read (293519) .... DONE<br>
Processing table: fud25_replace (0) .... DONE<br>
Processing table: fud25_search (30221) .... DONE<br>
Processing table: fud25_search_cache (304) .... DONE<br>
Processing table: fud25_smiley (51) .... DONE<br>
Processing table: fud25_stats_cache (1) .... DONE<br>
Processing table: fud25_themes (3) .... DONE<br>
Processing table: fud25_thr_exchange (0) .... DONE<br>
Processing table: fud25_thread (12994) .... DONE<br>
Processing table: fud25_thread_notify (32069) .... DONE<br>
Processing table: fud25_thread_rate_track (87) .... DONE<br>
Processing table: fud25_title_index (12062) .... DONE<br>
Processing table: fud25_user_ignore (11) .... DONE<br>
Processing table: fud25_users (868) .... DONE<br>
Backup Process is Complete<br>Backup file can be found at: <b>/opt/backup.latest</b>, it is occupying 60183617 bytes<br>
</td>
</tr>
</table>
</body>
</html>forum#
Re: problems after migration [message #39663 is a reply to message #39652] Fri, 16 November 2007 21:23 Go to previous message
andy_scouser is currently offline  andy_scouser   United Kingdom
Messages: 76
Registered: June 2003
Karma: 1
Member
add to buddy list
ignore all messages by this user
Sorted it, totally ignore the backup function and do it by just copying files from the old server and a mysqldump import.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Fudforum doesnt work in EGW
Next Topic: Admin log in problems
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Dec 13 04:27:42 EST 2018

Total time taken to generate the page: 0.00653 seconds