FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » SQL error - PL version on PostgreSQL on XP (invalid byte sequence for encoding "UTF8")
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
SQL error - PL version on PostgreSQL on XP [message #39717] Thu, 22 November 2007 16:59 Go to next message
setkos is currently offline  setkos   Poland
Messages: 2
Registered: November 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello,

Could you give me some advices how to manage with the problem below:

Warning: pg_query() [function.pg-query]: Query failed: ERROR: invalid byte sequence for encoding "UTF8": 0xb1 HINT: This error can also happen if the byte sequence does not match the encoding expected by the server, which is controlled by "client_encoding". in \FUD\index.php on line 95
(\FUD\index.php:95
\FUD\index.php:344
\FUD\theme\default\index.php:41
\FUD\index.php:1228
) : ERROR: invalid byte sequence for encoding "UTF8": 0xb1 HINT: This error can also happen if the byte sequence does not match the encoding expected by the server, which is controlled by "client_encoding".

What I already done:
-changed SET client_encoding to UTF8, WIN1252, WIN1250,
-changed SET DB encoding to UTF8, WIN1252, WIN1250,

but it still doesn't work and I have no more ideas what to do with it Sad .

My conf:
PostgreSQL 8.1 with C locales,
Apache 2.0.59,
XP.
Re: SQL error - PL version on PostgreSQL on XP [message #39726 is a reply to message #39717] Thu, 22 November 2007 18:52 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to change the encoding to ISO-8859-2



FUDforum Core Developer
Re: SQL error - PL version on PostgreSQL on XP [message #39788 is a reply to message #39726] Sat, 01 December 2007 12:57 Go to previous message
setkos is currently offline  setkos   Poland
Messages: 2
Registered: November 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Eh, so simple...I forget to change client_encoding LATIN2 Razz .

Thank you for advice Smile !
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Admin log in problems
Next Topic: Version 2.7.4 Generate PDF error message
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Dec 18 22:38:15 EST 2018

Total time taken to generate the page: 0.00660 seconds