FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Installing FUD Forum on multiple servers setup
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Installing FUD Forum on multiple servers setup [message #40046] Tue, 08 January 2008 04:38 Go to next message
Dont_Panic is currently offline  Dont_Panic   Sweden
Messages: 3
Registered: January 2008
Location: Stockholm, Sweden
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi

I've recently downloaded and installed FUD Forum on my local host environment for evaluation purposes. The one thing I noticed was that files were changed during my use of the forum (for example 'includes/globals.php' and cache-files).

On our live environment we have a two web server solution. Can FUD Forum still be used?
Re: Installing FUD Forum on multiple servers setup [message #40052 is a reply to message #40046] Tue, 08 January 2008 13:50 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
GLOBASLS.php would only change if you've changed the forum's global settings. You can always rsync those files or put them on NFS share so both machines can reference the same files.

FUDforum Core Developer
Re: Installing FUD Forum on multiple servers setup [message #40089 is a reply to message #40052] Mon, 14 January 2008 05:30 Go to previous messageGo to next message
Dont_Panic is currently offline  Dont_Panic   Sweden
Messages: 3
Registered: January 2008
Location: Stockholm, Sweden
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
[duplicate] - see below

[Updated on: Mon, 14 January 2008 08:20]

Report message to a moderator

Re: Installing FUD Forum on multiple servers setup [message #40092 is a reply to message #40052] Mon, 14 January 2008 08:19 Go to previous messageGo to next message
Dont_Panic is currently offline  Dont_Panic   Sweden
Messages: 3
Registered: January 2008
Location: Stockholm, Sweden
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello Ilia.

We've set up a NFS-share, but it doesn't seem to do the trick, it works on one server (the where the files is not physically stored, but I think that's because that server was the first to access the files).

The error message we keep getting is:

[Mon Jan 14 04:03:30 2008] [error] [client xxx.xxx.xxx.xxx] PHP Notice: Use of undefined constant fud_sql_lnk - assumed 'fud_sql_lnk' in /www/forum.xxxxxxxx.com/FUDforum2/index.php on line 19
[Mon Jan 14 04:03:30 2008] [error] [client xxx.xxx.xxx.xxx] PHP Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /www/forum.xxxxxxxx.com/FUDforum2/index.php on line 1

Our sysadmin thinks it has something to do wiht file locking by apache on the cache files.

Any ideas?

Re: Installing FUD Forum on multiple servers setup [message #40108 is a reply to message #40092] Mon, 14 January 2008 13:57 Go to previous message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
That constant is defined inside db.inc inside the src/ dir. Does that file get included or do you get inclusion errors ?

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Problem re-opening FUDforum after maintenance
Next Topic: No value in DBTYPE on the 2 step of installation
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Apr 21 05:45:06 EDT 2018

Total time taken to generate the page: 0.00641 seconds