FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » How To » [Solved]How do attached files works ?
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
[Solved]How do attached files works ? [message #40371] Wed, 20 February 2008 16:37 Go to next message
Arafel is currently offline  Arafel   France
Messages: 18
Registered: July 2006
Location: France
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello,

i succeeded reading forum files containing the body of the message.

I used a regexp to change the attached files (images)'s folder, and here is the result:

I'm sorry it's in french.
http://www.pvp-academy.info/?site=test

So, right now i can have this:
<img src="http://www.pvp-academy.info/forum/index.php?t=getfile&amp;id=707&amp;private=0" border=0 alt="http://www.pvp-academy.info/forum/index.php?t=getfile&amp;id=707&amp;private=0"><br />


But only the alt is shown (of course...), i would like to know how attached files works in order to display the image instead of having the alt.

Thanks for helping Smile

[Updated on: Mon, 25 February 2008 15:02]

Report message to a moderator

Re: How do attached files works ? [message #40377 is a reply to message #40371] Thu, 21 February 2008 08:40 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The image would show up if the user has access to see the downloaded file. What error are you seeing now?

FUDforum Core Developer
Re: How do attached files works ? [message #40394 is a reply to message #40371] Mon, 25 February 2008 14:06 Go to previous messageGo to next message
Arafel is currently offline  Arafel   France
Messages: 18
Registered: July 2006
Location: France
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
This is the apache error:

[error] [client 130.79.157.145] File does not exist: /var/www/pvpacademy.boeglin.org/images, referer: http://www.pvp-academy.info/?site=test

But when i use "show image" it's working.
When i post the image like this on the forum: [img ]http://pvp-academy.info/forum/index.php?t=getfile&id=722&private=0[ /img]
it's also working, so i don't get it.


after testing to direct link the image, onthis page:
http://boeglin.org/~alex/test.html

i get this apache error:
90.34.49.225 - - [25/Feb/2008:20:30:16 +0100] "GET /forum/index.php?t=getfile&id=306&private=0 HTTP/1.1" 404 - "http://boeglin.org/~alex/test.html" "Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.8.1.11) Gecko/20071128 Iceweasel/2.0.0.11 (Debian-2.0.0.11-1)"



Also, when i check a message being non-authentified, i only get the Alt text, and the image is not shown/displayed, example here:
http://www.pvp-academy.info/forum/index.php?t=msg&th=947&start=0

It looks like there is an auth problem with images.

[Updated on: Mon, 25 February 2008 14:38]

Report message to a moderator

Re: How do attached files works ? [message #40395 is a reply to message #40371] Mon, 25 February 2008 15:02 Go to previous message
Arafel is currently offline  Arafel   France
Messages: 18
Registered: July 2006
Location: France
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ok, i switched this option from Yes to No:

Attachment Referrer Check:
Check HTTP_REFERER of users before allowing users to download file attachments. If enabled, users who's HTTP_REFERER does not contain WWW_ROOT will be prevented from downloading the attachments.

And it's working now.

Thanks Smile
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Preview image in topic
Next Topic: clearing session table
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Oct 23 07:45:58 EDT 2017

Total time taken to generate the page: 0.00613 seconds