FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Today's Messages (off)  | Unread Messages (on) | Subscribed Forums (off) | Subscribed Topics (off) | Unanswered Messages (off)

Forum: Plugins and Code Hacks
 Topic: FUDAPI: Creating a forum?
Re: FUDAPI: Creating a forum? [message #187816 is a reply to message #187810] Sat, 16 November 2019 22:54
BugLaden is currently offline  BugLaden   Canada
Messages: 214
Registered: February 2002
Location: Westminster, MD
Karma:
Senior Member
add to buddy list
ignore all messages by this user

So this statement seemed to work in my code:

        //Create the forum
        require_once "/home2/bugladen/cake/tobacconerd/FUDforum/include/GLOBALS.php";
        require_once "/home2/bugladen/cake/tobacconerd/FUDforum/scripts/fudapi.inc.php";
        $id = db_qid('INSERT INTO 
			'. $GLOBALS['DBHOST_TBL_PREFIX'] .'forum (
				cat_id,
                name,
                date_created
            ) VALUES (
            '. GroupsController::FORUM_CATEGORY .',    
            '. _esc($group->name) .',
            now()
			)
		'); 

FORUM_CATEGORY is a constant set to the id of an existing category in the forum

The forum appears in the Admin->Forum Management just fine.

It just doesn't appear in the forum index page at all. Not sure why.


-=BugLaden

[Updated on: Sat, 16 November 2019 22:55]

Report message to a moderator

[more unread messages]



Current Time: Tue Nov 19 01:15:29 EST 2019

Total time taken to generate the page: 0.00651 seconds