FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Random forum lockouts...
Show: Today's Messages :: Unread Messages :: Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Return to the default flat view Create a new topic Submit Reply
Random forum lockouts... [message #41013] Wed, 07 May 2008 00:03 Go to previous message
krbvroc1 is currently offline  krbvroc1   United States
Messages: 31
Registered: February 2005
Karma:
Member
add to buddy list
ignore all messages by this user
While trying to update to 2.7.7 and perform some testing I am running into something very odd. It is hard to reproduce, but has occurred several times. Basically at various times after selecting 'Log out' something happens to the FUDforum and visiting the site just crashes.

By crashes, I mean a white screen. Very early in the index.php process it crashes in ses_update_status.
 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to
 use near '' at line 1<br />
Query: UPDATE fud26_ses SET sys_id='', forum_id=0, time_sec=1210112266, action='Browsing the &lt;a href=\&quot;index.php?t=index\&qu
ot;&gt;forum list&lt;/a&gt;', returnto='' WHERE id=<br />
Server Version: 5.0.22<br />


I am not sure why this is getting corrupted. Oddly there is no way to recover from this. Even removing all rows of the fud26_ses table does not recover. (A complete restore of the entire database is needed).

So far while debugging this, the only thing I have notice specifically is that when this happens, the entries in the fud26_ses have a 'action' of NULL. Normally the 'action' field says something like 'Browsing...' etc. 'returnto' is also NULL.

When this happens you cannot even log in via the adm control panel. Perhaps some other table is getting in a weird state because clearing the fud26_ses does not fix the issue, only a full database restore to an earlier version does.

Any ideas? Suggestion? Debugging tips?

[Updated on: Wed, 07 May 2008 00:05]

Report message to a moderator

[Message index]
 
Read Message
Read Message
Read Message
Previous Topic: alias and brackets
Next Topic: Problem with RSS
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Sep 29 10:36:10 EDT 2022

Total time taken to generate the page: 0.00791 seconds