FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » need advice on upgrading slightly broken legacy 2.7.7. forum
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Return to the default flat view Create a new topic Submit Reply
need advice on upgrading slightly broken legacy 2.7.7. forum [message #164486] Wed, 09 February 2011 11:19 Go to previous message
michiamano is currently offline  michiamano   United States
Messages: 9
Registered: April 2009
Karma:
Junior Member
add to buddy list
ignore all messages by this user
I inherited this forum and have put off upgrading for far too long because the 'Make forum datadump' (under Forum Data Management) and its command line equivalent suddenly stopped working a while back after some upgrades at Bluehost and I am very worried that I would not be able to roll back to the previous version if something goes wrong during the upgrade.

The regular backups I have are dumps of the forum database and backups of the /FUDforum directory.

My question is this - what do I need to have in order to be able to roll back if the upgrade goes wrong?

What steps would I need to follow to roll back? I'm assuming that the 'import forum data' might be similarly broken.

I do realize that I need to upgrade to 3.0 before I upgrade to the latest version.

I have used FUDForum for years across versions as a forum admin. I would put my abilities with PHP and mySQL at the "cut and paste" level Wink

Thanks!

[Updated on: Wed, 09 February 2011 11:22]

Report message to a moderator

[Message index]
 
Read Message
Read Message
Previous Topic: error message: FATAL ERROR: anonymous user's ID must be 1!
Next Topic: Parse error when posting or attempting consistency check (*Fixed*)
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Oct 22 22:29:52 EDT 2017

Total time taken to generate the page: 0.00644 seconds