FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Users login but are assigned to another users account
Show: Today's Messages :: Unread Messages :: Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Return to the default flat view Create a new topic Submit Reply
Users login but are assigned to another users account [message #187898] Fri, 12 June 2020 18:17 Go to previous message
Elliaison is currently offline  Elliaison   
Messages: 18
Registered: February 2011
Karma:
Junior Member
add to buddy list
ignore all messages by this user
Please help, major issue being experienced.

I was working on user/group permissions this morning to change permissions. I deleted a User group called Global Anonymous Users that I thought I had created years ago. (Maybe it was a default user group? Maybe unrelated?)

About 2 hours ago Users started reporting that they were posting under other user's accounts. I looked into it and found the following:
- If I was already logged in and refreshed my page, I showed that I was logged in under another user account.
- If I logged out, it would respond by taking me back to the Home page, but logged in as yet another user.
- While logged in to another user account, I could post as them, change their profile and act in all ways as that user. (This is particularly an issue when I'm logged in as an admin and other users gain my access.)
- When I logged out several times, it cycles through various user accounts until everyone is logged out.

I tried upgrading from 3.0.9. to 3.0.10 and that did not repair the issue. My backups are not running, it looks like they stopped about a year ago.


Options I can take:
- I can replace any files from my backups (3.0.9), but remember we are currently on 3.0.10.
- I can uninstall and reinstall.
- I can do whatever you intelligent people might suggest. (I did a backup today 3.0.10.) I need to not risk my data.

Any suggestions would be greatly appreciated.

Elliaison
[Message index]
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Failed getting archive size from
Next Topic: Wrong URL for Last Page - Link [ ยป ]
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun May 29 01:19:10 EDT 2022

Total time taken to generate the page: 0.00663 seconds