FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Installing with MySQL 8 fails - No MyISAM engine
Show: Today's Messages :: Unread Messages :: Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Return to the default flat view Create a new topic Submit Reply
Installing with MySQL 8 fails - No MyISAM engine [message #187925] Tue, 07 July 2020 10:49 Go to previous message
interestinglyaverage is currently offline  interestinglyaverage   United States
Messages: 5
Registered: July 2020
Karma:
Junior Member
add to buddy list
ignore all messages by this user
Hi everyone, new to FUDforum after a client introduced it to me. I have tried to install it on Digital Ocean using MySQL 8 managed database, and the installation fails with various errors about not being able to drop tables. After investigating the installation script, the issue is in the table creations, where the installer forces the table to be MyISAM regardless of the default. Commenting this line out of the installer fixed the issue for me.

Is the use of MyISAM required for FUDforum to function correctly, or will the forum perform properly using InnoDB? This is the new default engine for MySQL, and would likely perform better for a high traffic forum as it is designed for more read/write as opposed to MyISAM which I understood to be more high read low write?
[Message index]
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: fudforum CI
Next Topic: This error is a bug with PCRE
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Mar 07 12:39:02 EST 2021

Total time taken to generate the page: 0.02361 seconds