FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » General » FUDforum in eGroupWare » Threads disappear in Egroupware 1.2.104
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Return to the default flat view Create a new topic Submit Reply
Threads disappear in Egroupware 1.2.104 [message #33321] Fri, 25 August 2006 14:54 Go to previous message
Sigurdur is currently offline  Sigurdur   Iceland
Messages: 3
Registered: August 2006
Karma:
Junior Member
add to buddy list
ignore all messages by this user
Hello

I have a problem, I installed fudForum in a freshly installed eGroupware. I created couple of forums and couple of topics. Now, when I open a forum I get "There are no messages in this forum.". However, on the front page (where forums are listed) I get statistics that the forum contains 2 topics and 3 posts, it even says who is the most recent poster etc. I.e. everything looks normal on the front page.

I know the topics are stored in the database since I can read them by explicitly searching for them.

Once when trying to post a topic I got the following error, maybe it gives a hint:

Quote:

(C:\wwwserver\apachewww\apps\aq\egroupware\fudforum\3814588639\index.php:13 1
C:\wwwserver\apachewww\apps\aq\egroupware\fudforum\3814588639\theme\default \post.php:2805
C:\wwwserver\apachewww\apps\aq\egroupware\fudforum\3814588639\theme\default \post.php:1668
C:\wwwserver\apachewww\apps\aq\egroupware\fudforum\3814588639\theme\default \post.php:3751
C:\wwwserver\apachewww\apps\aq\egroupware\fudforum\3814588639\index.php:414
) 1062: Duplicate entry '4-2147483645-0' for key 1
Query: INSERT INTO phpgw_fud_thread_view (thread_id,forum_id,page,tmp) SELECT phpgw_fud_thread.id, phpgw_fud_thread.forum_id, 2147483645, CASE WHEN thread_opt>=2 AND (phpgw_fud_msg.post_stamp+phpgw_fud_thread.orderexpiry>1156531513 OR phpgw_fud_thread.orderexpiry=0) THEN 4294967294 ELSE phpgw_fud_thread.last_post_date END AS sort_order_fld FROM phpgw_fud_thread INNER JOIN phpgw_fud_msg ON phpgw_fud_thread.root_msg_id=phpgw_fud_msg.id WHERE forum_id=4 AND phpgw_fud_msg.apr=1 ORDER BY sort_order_fld DESC, phpgw_fud_thread.last_post_id DESC
Server Version: 4.1.21-community-nt


I guess this is a known problem, since I vaguely remember seeing the same behaviour of missing topics on a Linux server some time ago, but I havent found a solution by searching these forums.

My setup is:
MySQL v4.1.21
Apache v2.0.59
FudForum: v2.6.0
Windows 2000 Professional SP4
Egroupware v1.2.104

[Edit: Rewrote parts of the text]

[Updated on: Sat, 26 August 2006 13:12]

Report message to a moderator

[Message index]
 
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: full text search of threads in egroupware fudforum
Next Topic: German language trouble in eGroupware post.php T_String 2018
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 17 07:38:42 EDT 2017

Total time taken to generate the page: 0.00684 seconds