FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » anonymous users aren't logged with IP
Show: Today's Messages :: Unread Messages :: Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
anonymous users aren't logged with IP [message #1486] Tue, 16 April 2002 19:22 Go to next message
Olliver   Germany
Messages: 443
Registered: March 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Hello,
guess I should have arrived earlier with the prob to be right in time with the 1.2.5 update, but this is something I ve just discovered yesterday Wink. I changed the forum's setting to allow anonymous users creating threads and messages and there it struck me that the admin cannot see the anonymous user's IP, only those of registerred members. I think this behaviour should change to *all* ppl's addresses being revealed to the admin, in order to make it possible to track down spamming or offensive postings. In that connection I want to mention that the "partial ressolving address" feature doesn't work for anonymous either. Maybe sth to fix in 1.2.6? Wink
bye
Ken
Re: anonymous users aren't logged with IP [message #1487 is a reply to message #1486] Tue, 16 April 2002 20:40 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Ken Kizaki wrote on Tue, 16 April 2002 7:22 PM

Hello,
guess I should have arrived earlier with the prob to be right in time with the 1.2.5 update, but this is something I ve just discovered yesterday Wink. I changed the forum's setting to allow anonymous users creating threads and messages and there it struck me that the admin cannot see the anonymous user's IP, only those of registerred members. I think this behaviour should change to *all* ppl's addresses being revealed to the admin, in order to make it possible to track down spamming or offensive postings. In that connection I want to mention that the "partial ressolving address" feature doesn't work for anonymous either. Maybe sth to fix in 1.2.6? Wink
bye
Ken


I'll take a look & post a fix...


FUDforum Core Developer
Re: anonymous users aren't logged with IP [message #1495 is a reply to message #1486] Wed, 17 April 2002 13:42 Go to previous messageGo to next message
hackie is currently offline  hackie   Canada
Messages: 177
Registered: January 2002
Karma: 0
Senior Member
Core Developer
add to buddy list
ignore all messages by this user

Fixed. here is the fixed file.
  • Attachment: drawmsg.inc
    (Size: 17.32KB, Downloaded 2017 times)


cc intelligence.c -o intelligence
$ ./intelligence
Segmentation fault
icon7.gif  Re: anonymous users aren't logged with IP [message #1510 is a reply to message #1495] Wed, 17 April 2002 21:06 Go to previous message
Olliver   Germany
Messages: 443
Registered: March 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Hello,
thanx a lot for ur fast help Smile
bye
Ken
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Thread rating feature slightly confusing
Next Topic: private message bug
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Jul 23 02:09:16 EDT 2024

Total time taken to generate the page: 0.05264 seconds