FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Attachments in newsgroups aren't decoded
Show: Today's Messages :: Unread Messages :: Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Message by icarus is ignored  [reveal message]  [reveal all messages by icarus]  [stop ignoring this user] Go to next message
Message by kerryg is ignored  [reveal message]  [reveal all messages by kerryg]  [stop ignoring this user] Go to previous messageGo to next message
Re: Attachments in newsgroups aren't decoded [message #159304 is a reply to message #159303] Fri, 22 May 2009 00:59 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3771
Registered: December 2004
Karma: 28
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
That's correct, MIME attachments are currently supported in E-mails, but not in USENET posts. We will fix it in a later release.
Message by icarus is ignored  [reveal message]  [reveal all messages by icarus]  [stop ignoring this user] Go to previous messageGo to next message
Re: Attachments in newsgroups aren't decoded [message #159313 is a reply to message #159311] Fri, 22 May 2009 10:45 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3771
Registered: December 2004
Karma: 28
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Hi,

The code was written in an era where E-mail messages had MIME attachments and USENET had UUencoded attachments. Now that MIME is also used for USENET, a common function makes sense.

I won't get to this any time soon. However, you are welcome to take the initiative to get the job done. To get you started, have a look at scripts/maillist.php, scripts/nntp.php, include/mlist.inc and include/nntp.inc.

Best regards.

Frank
Re: Attachments in newsgroups aren't decoded [message #159767 is a reply to message #159313] Sun, 21 June 2009 21:39 Go to previous message
jcarter is currently offline  jcarter   United States
Messages: 25
Registered: August 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Fri, 22 May 2009 10:45
Hi,

The code was written in an era where E-mail messages had MIME attachments and USENET had UUencoded attachments. Now that MIME is also used for USENET, a common function makes sense.

I won't get to this any time soon. However, you are welcome to take the initiative to get the job done. To get you started, have a look at scripts/maillist.php, scripts/nntp.php, include/mlist.inc and include/nntp.inc.




I implemented this several years ago, but was too lazy to post the patch. I'll post it to {patches} for the latest release. It still doesn't solve the problem of large binary messages in which an attachment is split across several messages.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: can't login to the admin panel
Next Topic: NNTP Sync minor quirks
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri May 24 13:36:58 EDT 2024

Total time taken to generate the page: 0.06856 seconds