FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Upgrade script does not work
Show: Today's Messages :: Unread Messages :: Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Message by basse is ignored  [reveal message]  [reveal all messages by basse]  [stop ignoring this user] Go to next message
Re: Upgrade script does not work [message #981 is a reply to message #980] Mon, 18 March 2002 17:13 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
djupsjob wrote on Mon, 18 March 2002 4:00 PM

I ran the upgrade scripts for 1.x to 1.2.3 and got this:


Must be able to write to the UPDATE_STATUS
Execute the following lines
chmod 777
chmod -f 666 UPDATE_STATUS


I tried to execute the lines but the file UPDATE_STATUS is nowhere to be found. What's wrong?



Nothing wrong, simply you're doing the upgrade for the 1st time and the file is not there...

Your safe_mode settings do not allow the upgrade script to create the file I believe...

Could you tell me what are the permissions (including owner) of the errors directory?


FUDforum Core Developer
Message by basse is ignored  [reveal message]  [reveal all messages by basse]  [stop ignoring this user] Go to previous messageGo to next message
Re: Upgrade script does not work [message #1008 is a reply to message #1004] Tue, 19 March 2002 11:43 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Okie 1 last question then, could you please open your GLOBALS.php file and tell me what is the path you have to the error directory.

FUDforum Core Developer
Message by basse is ignored  [reveal message]  [reveal all messages by basse]  [stop ignoring this user] Go to previous messageGo to next message
Re: Upgrade script does not work [message #1017 is a reply to message #1016] Tue, 19 March 2002 18:32 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
djupsjob wrote on Tue, 19 March 2002 6:29 PM

prottoss wrote on Tue, 19 March 2002 6:43 PM

Okie 1 last question then, could you please open your GLOBALS.php file and tell me what is the path you have to the error directory.

/www/int2000/a/7676/html/forum_data/errors/


Is this what ALL your GLOBALS.php file say, especially the one in the forum's main web dir?



FUDforum Core Developer
Message by basse is ignored  [reveal message]  [reveal all messages by basse]  [stop ignoring this user] Go to previous messageGo to next message
Re: Upgrade script does not work [message #1049 is a reply to message #1034] Wed, 20 March 2002 10:53 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
There should be ONLY 1 GLOBALS.php file and it should be inside the include dir. There are to symlinks to this file, 1 from adm/ directory and one from the forum's main web dir.

I wanted to make sure you do not have multiple copies of the GLOBALS.php file in your forum installation. Some FTP clients tend to replace simlinks with REAL files when you're uploading.


FUDforum Core Developer
Message by basse is ignored  [reveal message]  [reveal all messages by basse]  [stop ignoring this user] Go to previous messageGo to next message
Re: Upgrade script does not work [message #1055 is a reply to message #1052] Wed, 20 March 2002 14:24 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
No symlinks?

Hmmm that would DEFINATELY be a problem.

Try creating them yourself and then run the update script.


FUDforum Core Developer
Message by basse is ignored  [reveal message]  [reveal all messages by basse]  [stop ignoring this user] Go to previous messageGo to next message
Re: Upgrade script does not work [message #1057 is a reply to message #1056] Wed, 20 March 2002 15:38 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
djupsjob wrote on Wed, 20 March 2002 3:36 PM

Could it be the lousy safe_mod that's behind the problems again?

This might be a stupid question, but how do I create symlinks with an ftp client? I've never done that before and when I tried it didn't work quite as I expected.



the command is called "symlink [source] [dest]"

ex: symlink /some/dir/blah/GLOBALS.php /new/dir/cool/GLOBALS.php


FUDforum Core Developer
Message by basse is ignored  [reveal message]  [reveal all messages by basse]  [stop ignoring this user] Go to previous messageGo to next message
Re: Upgrade script does not work [message #1066 is a reply to message #1065] Wed, 20 March 2002 17:11 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
djupsjob wrote on Wed, 20 March 2002 4:59 PM

Is there any other way to do this? All my ftp clients spit out "server said SITE SYMLINK not understood" in one form or another.


you can use php to do that:


exec("ln -s /source/GLOBALS.php /dest/GLOBALS.php");


FUDforum Core Developer
Message by basse is ignored  [reveal message]  [reveal all messages by basse]  [stop ignoring this user] Go to previous messageGo to next message
Re: Upgrade script does not work [message #1121 is a reply to message #1107] Thu, 21 March 2002 10:46 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The 2 symlinks I've mentioned in previous messages are the only ones that the forum creates.

you can create UPDATE_STATUS file your self by doing:

exec("touch /path/to/file/UPDATE_STATUS");

This way the file will have webserver's UID & GID and the upgrade script will be able to edit the file...


FUDforum Core Developer
Message by basse is ignored  [reveal message]  [reveal all messages by basse]  [stop ignoring this user] Go to previous messageGo to next message
Re: Upgrade script does not work [message #1135 is a reply to message #1134] Thu, 21 March 2002 14:38 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Hm... if the symlinks are not there, I cannot imagine the forum working at all. Could it be that your FTP client is hiding the symlinks from you? Can you running ls -lia via your FTP client?

FUDforum Core Developer
Message by basse is ignored  [reveal message]  [reveal all messages by basse]  [stop ignoring this user] Go to previous messageGo to next message
Re: Upgrade script does not work [message #1145 is a reply to message #1143] Thu, 21 March 2002 14:52 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
yeah it should, I suggest we meet on IRC at some point, its realtime nature would probably help us solve this issue MUCH quicker Smile

Drop by our irc channel #fudforum on irc.openprojects.net and hopefully solve this problem.

From what I recall the MAIN problem was the fact that UPDATE_STATUS file was missing.


FUDforum Core Developer
Re: Upgrade script does not work [message #1151 is a reply to message #980] Thu, 21 March 2002 17:38 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Problem Resolved.

Once again we must thank the person who invented safe_mode in php, for that piece of "brilliant" code.


FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: E-mail Problem
Next Topic: Error
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Jun 24 22:56:04 EDT 2024

Total time taken to generate the page: 0.04045 seconds