FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » private message bug
Show: Today's Messages :: Unread Messages :: Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
private message bug [message #1501] Wed, 17 April 2002 16:47 Go to next message
npf77 is currently offline  npf77   France
Messages: 7
Registered: March 2002
Location: France
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello,
I got this when I try to send a private message (send or reply):

Query Failed: INSERT INTO fud_pmsg ( ouser_id, duser_id, to_list, ip_addr, host_name, post_stamp, icon, mailed, folder_id, subject, attach_cnt, smiley_disabled, show_sig, track, read_stamp, ref_msg_id ) VALUES( 107, 107, 'xxxxxx', 'xxx.xxx.xxx.xxx', NULL, 1019076045, NULL, 'Y', 'DRAFT', 'Re: Hi, how to make the install patch please', 0, 'N', 'N', 'N', 1019076045, 'F' )
Reason: Unknown column 'ref_msg_id' in 'field list'
From: /home1/forum/www/docs/forum/ppost.php
Server Version: 3.23.45-log

What's wrong ?

Nota: that occures on THIS forum: support forum at fud.prohost.org for info.



Re: private message bug [message #1503 is a reply to message #1501] Wed, 17 April 2002 18:14 Go to previous messageGo to next message
hackie is currently offline  hackie   Canada
Messages: 177
Registered: January 2002
Karma: 0
Senior Member
Core Developer
add to buddy list
ignore all messages by this user

Whoos a problem with the Update script, I forgot to make it update the fud_pmsg table.

I'll make an "emergency" 1.2.6 release within the hour, with the fix.

Please note this bug ONLY affects people who upgraded, it does not affect new installations of 1.2.5 & above.


cc intelligence.c -o intelligence
$ ./intelligence
Segmentation fault
Re: private message bug [message #1507 is a reply to message #1501] Wed, 17 April 2002 20:56 Go to previous messageGo to next message
mauftarkie   United States
Messages: 29
Registered: April 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

More on this. I ran into this today, too, but noticed that 1.2.6 was available for download. (btw: the upgrade links say 1.2.6 but really points to 1.2.4; it was the same way with 1.2.5).

After I upgraded, I now get this error when trying to POST a new private message:

Quote:

Query Failed: UPDATE fud_pmsg SET nrf_status='F' WHERE id=
Reason: You have an error in your SQL syntax near '' at line 1
From: .../forum/ppost.php
Server Version: 3.23.49-log


I'm still trying to wrap my brain around the ppost.php code, but it's slow going for me as this is the first time I've really looked hard at the code...

Any insight is appreciated. Smile
Re: private message bug [message #1508 is a reply to message #1501] Wed, 17 April 2002 20:59 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Today just isn't my day Smile.

FIXED, thanks.


FUDforum Core Developer
Re: private message bug [message #1509 is a reply to message #1507] Wed, 17 April 2002 21:01 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
mauftarkie wrote on Wed, 17 April 2002 8:56 PM

More on this. I ran into this today, too, but noticed that 1.2.6 was available for download. (btw: the upgrade links say 1.2.6 but really points to 1.2.4; it was the same way with 1.2.5).

After I upgraded, I now get this error when trying to POST a new private message:

Quote:

Query Failed: UPDATE fud_pmsg SET nrf_status='F' WHERE id=
Reason: You have an error in your SQL syntax near '' at line 1
From: .../forum/ppost.php
Server Version: 3.23.49-log


I'm still trying to wrap my brain around the ppost.php code, but it's slow going for me as this is the first time I've really looked hard at the code...

Any insight is appreciated. Smile


that is updated when you reply or forward the message, and it used in the message list to show you whether you have replied or forwarded a particular message.


FUDforum Core Developer
Re: private message bug [message #1511 is a reply to message #1509] Wed, 17 April 2002 21:08 Go to previous messageGo to next message
mauftarkie   United States
Messages: 29
Registered: April 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

prottoss wrote on Wed, 17 April 2002 6:01 PM

that is updated when you reply or forward the message, and it used in the message list to show you whether you have replied or forwarded a particular message.


Well, I'm going to Members and selecting the "pm" icon on the right hand side under "Action". I type a subject, a quick message body, and hit send. Blammo. I get the error message.

I did look at the form variables that I was sent:

<input type="hidden" name="S" value="1bede4180434dd7abfe0a5e2e74dff91">
<input type="hidden" name="msg_id" value="">
<input type="hidden" name="reply_to" value="">
<input type="hidden" name="forward" value="">
<input type="hidden" name="old_subject" value="">
<input type="hidden" name="msg_ref_msg_id" value="">
<input type="hidden" name="prev_loaded" value="1">

Seems right to me. There has to be something I'm missing.
Re: private message bug [message #1512 is a reply to message #1511] Wed, 17 April 2002 21:26 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
are you running 1.2.6?

FUDforum Core Developer
Re: private message bug [message #1513 is a reply to message #1512] Wed, 17 April 2002 21:31 Go to previous messageGo to next message
mauftarkie   United States
Messages: 29
Registered: April 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

yes, I'm running 1.2.6.

I tried sending a message to one of my non-admin accounts. Turns out that despite the error, the message is still sent. I now feel sorry for the person I was trying to send a private message to, as I'm sure he has a dozen or more of them from me by now. Smile
Re: private message bug [message #1514 is a reply to message #1513] Wed, 17 April 2002 21:38 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
mauftarkie wrote on Wed, 17 April 2002 9:31 PM

yes, I'm running 1.2.6.

I tried sending a message to one of my non-admin accounts. Turns out that despite the error, the message is still sent. I now feel sorry for the person I was trying to send a private message to, as I'm sure he has a dozen or more of them from me by now. Smile


Could you give me the URL to your forum, I'd like to try to see if I can relicate the bug myself. Of course if you can replicate the bug on this forum it would be even better Smile


FUDforum Core Developer
Re: private message bug [message #1515 is a reply to message #1514] Wed, 17 April 2002 21:46 Go to previous messageGo to next message
dria   Canada
Messages: 6
Registered: April 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I'm getting the same error, both on a new 1.2.6 install and on an updated 1.2.6 install (I installed 1.2.6 then the 1.2.6 update hoping that the fix was included).

I think the problem is on line 260 of includes/private.inc...the .$id value doesn't seem to be getting passed properly.

Re: private message bug [message #1516 is a reply to message #1514] Wed, 17 April 2002 21:47 Go to previous messageGo to next message
mauftarkie   United States
Messages: 29
Registered: April 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

I just sent you a private message w/forum URL. And yes, I got the same error here:

Quote:

Query Failed: UPDATE fud_pmsg SET nrf_status='F' WHERE id=
Reason: You have an error in your SQL syntax near '' at line 1
...
Server Version: 3.23.45-log

Re: private message bug [message #1517 is a reply to message #1515] Wed, 17 April 2002 21:52 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Okie... this is DEFINATELY not my day....

The bug you reported is actually something that was fixed in 2.0 Alpha but was never backported to 1.2.X

Attached is a file which should fix the problem.

Please give it a go and if let me know if it fixed the problem or not. The sooner the better I'll make 1.2.7 then.
  • Attachment: ppost.php
    (Size: 26.44KB, Downloaded 803 times)


FUDforum Core Developer
Re: private message bug [message #1518 is a reply to message #1517] Wed, 17 April 2002 21:55 Go to previous messageGo to next message
mauftarkie   United States
Messages: 29
Registered: April 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

Yep, that did it. Thanks for the prompt response!
Re: private message bug [message #1519 is a reply to message #1518] Wed, 17 April 2002 21:56 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
woohooo.....

yet another one bites the dust...


1.2.7 time Razz


FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: anonymous users aren't logged with IP
Next Topic: Mailingproblem
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon May 27 09:53:01 EDT 2024

Total time taken to generate the page: 0.04573 seconds